7

For the past two years I have been using John Maisey's most excellent iCal Reply Checker to take control over iCal's aggressive notification emails. Sadly, it doesn't work in OS X 10.6. (John clearly states on his web site that it's for 10.4 and 10.5, so this is entirely my fault, not at all his.)

Does anyone know another way to prevent iCal from sending mail?

5

iCal Reply Checker is updated for OS X 10.6 now.

| improve this answer | |
  • This doesn't seem to be in development any more. The latest version (February 2013) supports "OSX 10.4 to OSX 10.8 iCal/Calendar.app with local calendars (i.e. calendars under 'On My Mac')" – Joshua Goldberg Jul 24 '18 at 23:17
4

Almost 4 years and 4 major OS releases later and the problem still exists (as far as I can tell). How is it Apple hasn't fixed this yet?

Anyway my (free) workaround is to temporarily disable networking while accepting an invite. Specifically, I created another network location called "None" without any configured interfaces, then to accept an invite without sending a response:

  1. switch network location to "None" (click the apple icon in the menu bar -> Location -> None)
  2. accept the event
  3. wait for the response to show up in Mail's outbox
  4. delete it from the outbox
  5. switch back to original network location

Ugly, but it works...

| improve this answer | |
  • In the realm of "ugly, but it works", I have resorted to manually entering the events into iCal myself and then deleting the invites without clicking on the iCal attachment. – Alan Apr 20 '13 at 16:09
2

I use iCal and i don't get email notifications. Are you sure there isn't a setting in the preferences to disable that?

| improve this answer | |
  • There is nothing in the preferences (that I can see) to prevent iCal from automatically emailing my responses to invited events. There is an option to "ask before sending changes to events", but that's different than the emailing of my acceptance of decline actions. – Alan Sep 2 '09 at 2:36
1

All you have to do is wait a little longer :). There's a thread on the Apple Support page about this issue. Here's the response from the creator of iCal Reply Checker:

FYI I expect to update iCal Reply Checker shortly for 10.6

The answer was given on September 4th.

| improve this answer | |
  • Yeah... I have John's site bookmarked on my desktop and have been checking it daily. – Alan Sep 8 '09 at 1:07
0

Based on @MisterEd's solution:

I tried to turn off my internet connection and wait for the emails to show up in the outbox, but sometimes, they didn't.

The solution was to add an /etc/hosts entry that would send my SMTP server to a garbage IP. For example:

169.254.0.0    smtp.example.com

Then, turn on your internet and delete the emails when they appear in the Outbox.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.