I noticed that Unicode characters suddenly stopped displaying in some applications, so far Notepad++ and Skype, when they were appearing previously. Instead they appear as boxes. They were working before, but I believe that it broke after a restart. I can even type them into the Skype input window and see them, but then after submitting the message they appear as boxes.

For example: 햇반 and 県 will not show up in either Skype or notepad++, but they do appear just fine in Chrome as I am typing this.

No new software was installed before or after the last restart, the only thing that happened were some Windows updates. The document in Notepad++ has the encoding set to UTF-8

Windows 7 x64


5 Answers 5


I had this issue. Stumbled upon the following setting in Windows 7 (professional):

 Control Panel --> All Control Panel Items --> Fonts --> Font settings

Hide fonts based on language settings was enabled. I disabled it and a big chunk of fonts appeared for me ... which allowed Eclipse to start displaying fonts that had been hidden.

In eclipse, I can now see all the nice UTF-8 characters I was using ... after I adjusted my fonts to allow it again. The original font that was assigned, 'Courier New' was displaying the items as boxes, as you described.

  1. Go to "Control Panel" -> "Region and Language" -> "Administrative" -> "Change system locale..."
  2. Change the locale to the one you're having problem with, and then change it back.

enter image description hereclick to enlarge

EDIT: Worked out a better solution that worked for me:

Make a file (any kind of file) on the Desktop that has some character of that language in the file name

  • I was having the same problem. At first, I didn't try this answer because it seemed too silly. Several hours later, I tried it out of desperation. It worked. Wonder what causes this strange issue?
    – Tom Clift
    Jun 18, 2012 at 5:56
  • @TomClift Clift Whenever there is a system update, or an "user profile" or home directory change (my company network does it all the time) I get the problem again. don't know what's the exact cause, but I think it's related to those.
    – nemo
    Jun 25, 2012 at 16:42

The obvious suspect is fonts - not all fonts have full unicode support.

  • 2
    Would the fonts have suddenly changed themselves in every program though? I'm also noticing that the characters don't display when I play Team Fortress 2 either. Everything displayed just fine a few days ago.
    – nmkef
    Sep 16, 2011 at 7:46

Chrome can cause the problem, which happened to me on Win7 x64. Basically it only happens if Chrome is the first app to show the Chinese characters.

See this other SuperUser post for more information:

My Windows 7 has suddenly stopped displaying Unicode symbols


Another program may be changing the font settings or affecting it. I lose my stars icon in Virtual DJ after I have been using Adobe Fireworks. (By the way, Fireworks doesn't show all fonts which I have in other areas of my computer.) I'm pretty sure one program is affecting the other, somehow.

Not the answer you're looking for? Browse other questions tagged or ask your own question.