I've recently started using a Mac at work, and after having been used to PCs running Linux for many years, it's taken a while for me to resolve a few niggles. But there's still one that remains: I'm using a MacBook Pro which has an English (British) keyboard, and the following separate keyboard:

Apple English (British) keyboard

My problem is that the output from section key (§±, top left, under esc) is switched with the grave accent / backtick key (`~, bottom left, by the shift key), on the external keyboard only. They produce the correct output on the built-in keyboard. I have searched far and wide for a solution, but found nothing. I have looked at Ukelele to remap the keys, but as the built-in keyboard is working as expected, this doesn't appear to be of any use.

Can anyone help me switch the output of these keys?

  • What keyboard is this? It looks quite nice... – Daniel Beck Sep 17 '11 at 11:55
  • @Daniel: How is it any different to the unergonomic wired keyboards supplied with iMacs and Mac Pros? – paradroid Sep 17 '11 at 12:36
  • @paradroid They have white keys and a smaller border, at least the one I'm using from 2008(ish). – Daniel Beck Sep 17 '11 at 12:41

Two keyboard mapping products :

KeyRemap4MacBook (last release august 2011)
DoubleCommand (last release november 2009)

I believe that KeyRemap4MacBook can differentiate between the external and internal keyboards.

  • Thanks for the links. Unfortunately, the version of KeyRemap4MacBook that I need for Mac OS X 10.5.8 doesn't have the option to create my own mappings, and the included mappings are not suitable. DoubleCommand doesn't do the job either. I need to update Mac OS X at some point, so maybe that will fix it. If not, I should be able to use the later version of KeyRemap4MacBook then. – Mike Sep 22 '11 at 7:56
  • I agree that updating to the latest version can only improve the situation. If you then still need remapping that KeyRemap4MacBook cannot do, then you can contact the developer and suggest an improvement. – harrymc Sep 22 '11 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.