After installing the Windows 8 Developer Preview (64-bit) on my PC, I can no longer see my DVD drive. What could be wrong?

My PC specifications:

  • Gigabyte GA-EP41T-UD3L (G41) motherboard
  • Samsung DVD (connected via SATA)
  • Intel Core 2 Duo 2.93GHz
  • 4GB DDR3 RAM
  • ATI Radeon HD 4600 Series 1GB

The "Hide Empty Drives" option has been Unchecked, but had no effect.

  • 1
    You included all the information except the most important one. Your DVD bone is connected to the SATA bone, which is connected to the Motherboard bone. . . – surfasb Sep 17 '11 at 15:35
  • sorry my DVD is Samsung (SATA) and the Motherboard is Gigabyte Ep41T-UD3l (G41) – Mohamed Magdy Sep 17 '11 at 15:38
  • You can't see the DVD drive (which may be an explorer option for 'Hide Empty Drives'), or the DVD drive doesn't show up in the 'Device Manager' of the desktop version of control panel (ie: not the metro one)? – Ritch Melton Sep 17 '11 at 15:44
  • 2
    @surfasb... "bone"? – nhinkle Sep 17 '11 at 17:17
  • 2
    You realize this is pre-beta software? Who knows what will work or not work on any given hardware. – Moab Sep 18 '11 at 15:06

Windows8 is still in its infancy, and many drivers are not yet stable enough to deploy to Windows8. Unfortunately this means that you will not be able to use your drive on the Windows8 CP until either the Windows8 RC or unless the manufacturer of the drive releases drivers compatible with the Win8 CP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.