The only way I have been able to reliably load a windows install disc onto USB is using Unetbootin and a FAT32 formatted drive. I do this because it is significantly faster to install windows this way than using an optical drive, and I also do not have optical drives connected to most of my computers. I have tried YUMI, but the loading of the Win7 installer iso fails while it's loading up.

Now unetbootin doesn't allow me to choose to append more images, but I'd like to have memtest86 on the same drive as my win7 USB. All the other testing tools I can run from within windows, except for memtest.

So I've got syslinux.cfg opened up and it looks like this:

default menu.c32
prompt 0
menu title UNetbootin
timeout 100

label unetbootindefault
menu label Default
kernel /ubnkern
append initrd=/ubninit 

I tried to add 4 lines at the bottom.

label memtest
menu label Launch Memtest86+
kernel memdisk
append initrd=/memtestp.img

I grabbed an image from this post: image and I put it into the root dir along with syslinux.cfg. Renamed it to memtestp.img.

It still boots up the windows installer when I try to boot from it.

Could somebody help explain what the lines in the config file do, and which wrong assumptions I have taken? Does unetbootin use some type of GRUB-like bootloader that is capable of letting me choose what image to boot?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.