I need to upgrade PHP so that I can upgrade joomla on my dedicated server. I have:

  • kloxo 6.1.6
  • php-5.2.17-1
  • Linux CentOS-55-64-minimal 2.6.18-194.32.1.el5 x86_64 x86_64 x86_64 GNU/Linux

I searched everywhere and I could only find that PHP 5.3 isn't compatible with zend. I would like to upgrade to 5.2.4, which is the minimum for joomla 1.6 and 1.7.

I tried to run:

yum update php.x86_64

Which is the PHP package installed, but it didn't work.

This is a production server with quite a few users across many sites, so I wanted to do it as safely as possible.

Is it safe to run "yum update"? It showed me 6 packages to install and 125 packages to update, including a kernel. Is that safe? I haven't touched kloxo's yum repositories.


I just successfully ran "yum update".

Now I think I need to know how to add a new repository that has the 5.2.4 and how to update to that specific version.

Any ideas?

  • Can't you just update to CentOS 6? It has newer versions of everything.
    – jgillich
    Apr 26 '13 at 16:47

Remi's repository has always been a good choice for PHP (and mysql) versions beyond the official distro releases:


You'll need to setup the repo and then make sure the specific version you want is available.


I found the problem!

My PHP configuration was ignoring the parse_ini_file function, which is used since joomla 1.6. This was a default behaviour of kloxo, which has brought me a few headaches and endless wasted hours.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.