I'm having some weird connection problems with my home Wi-Fi network (ZyXEL adsl P-660HW-D1). I have a few devices connected to it, both by Ethernet wire and Wi-Fi, and only two of the devices have exhibited any symptoms (both of them owned and actively used by me). Any visiting device I've tried connecting to my home Wi-Fi has had no trouble. Both of the devices with problems work perfect in other Wi-Fi networks.

First there have been some connection problems with one (but only one!) of the computers connected to my network: Asus Eee PC 1001PX netbook (with Atheros AR2427 Wireless Network Adapter, running Xubuntu 9.10) 1) It has some random trouble connecting to the wlan (authentication failure), but when it gets a connection it stays connected without connection issues. 2) Sometimes ping results show some random packets with weirdly long latency, and occasional lost packet (<2% if even that).

Second, more serious is that my new Android device (GT-S5570 running 2.2.1) is having connection trouble. The device connects ok, gets an IP address, and sees all other computers on the network (using Overlook Fing). However, ping results are rather mixed. Depending on the attempt results come back with packet loss of anything from 100% to 0%, usually one or the other, but something around 20% or 60% happens quite often too. This happens trying to ping any of the devices on network, including the gateway (which, of course, is the problem). Other devices can ping each other just fine, independent of connection type (Wi-Fi or Ethernet wire).

The Android device always gets a connection, and stays connected to the Wi-Fi even when it's getting 100% packet loss.

The router has the original (which is also the latest) firmware, and I haven't meddled with the settings it came with - I woudn't know which settings to meddle with. Both devices have good signal strength. There are no conflicting Wi-Fi networks around.

How do I debug this further? What Wi-Fi settings could be causing this?

(Cross-posted to Android Enthusiasts since the main problem concerns the Android device.)


In my case, the solution was simply to flash the router firmware. No idea why it worked, but it wasn't any user changeable settings that were changed by the firmware change.

I've been having similar problems with my Samsung Gio S5665. It would connect perfectly to the Wi-Fi at the office, but at home: connects with excellent to good signal strength, but pinging the router produces no response usually; occasional random bursts of return packets for 4 to 10 seconds; disabling and reenabling wifi on my phone results in 100% packet return for about 60-180 seconds, then back to occasional bursts.

All other devices including other phones connect to the home Wi-Fi correctly.

What I tried:

  • Changing protection on router from WPA/WPA2 to WPA only, WPA2 only, WEP only, none. No difference. Encryption from TKIP to AES: No difference

  • Changing channels, sideband, power, beacon rate, in short, everything changeable: No difference or worse.

  • On the phone: Changing ip address to static. No difference.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.