I noticed this happen right around the same time I noticed a stuck red pixel in the middle-lower section of the panel. I don't think the two things are related but they may be since it was about the same time. To be more specific, it seems to be a stuck red sub-pixel: when displaying white, it isn't visible.

Windows used to know the name of the monitor, and displayed it in the "screen resolution" screen, but now it calls it a "Generic Non-PnP Monitor".

What is strange is that it now gets detected with a strange resolution of 1919x1200. The monitor hardware itself appears to be mysteriously reporting that one of its vertical scanlines is gone. I am very very glad indeed that it has chosen to treat whatever failure it's encountered in this graceful manner rather than simply stop working, but I am ever curious about just what it is that actually happened.

I don't know how I can test this without physically counting pixels. There's just too many lines. Since windows (and almost every game I've played on this computer since) recognize the screen has having 1919 horizontal res, I feel pretty certain that the configuration signals being sent by the monitor is actually a 1919x1200 one.

Has this ever happened to anybody else? What could have gone wrong in the hardware to cause this?

Update: I've been trying to install Ubuntu 12.04 and I had this monitor connected. The loading of the liveDVD image (on USB) kept hanging during loading and it wasn't showing any errors that meant anything to me.

Then I gave up on Ubuntu and tried loading up Linux Mint 13 64-bit. This time before it hung up it displayed some helpful info which claimed something to the effect of "EDID invalid". Which makes a lot of sense. So i plug in a different display and the thing loads up just fine.

I guess that means it's an EDID problem.

The question is still not solved! How can I fix the EDID? Is this stored in some ROM chip on the display, in which case I'm screwed? It is impossible to install Linux when this monitor is plugged in with DVI and I have tried for a long time to get it working above 640x480 (where the Nvidia control panel window does not even fit the screen) with no success. I will be relegated to using the monitor only with VGA it seems.

  • What's the dimension of a printscreen image? What monitor+graphics card do you have? – RJFalconer Sep 18 '11 at 16:58
  • 2
    I blame the Pixel Fairy. – RJFalconer Sep 18 '11 at 16:58
  • @RJFalconer the screen capture is 1919x1200 res. Yes, I would just blame the Pixel Fairy and be done with it but the whole thing is just strange. It actually made me realize that when I set the resolution settings for my graphics applications that I cannot simply hardcode a couple of common resolutions and set them. I have to instead use the system's APIs to determine the list of valid supported resolutions. Because I bet if I tried to set fullscreen 1920x1200 at this point it will fail spectacularly. – Steven Lu Sep 18 '11 at 19:08
  • 1
    I've got it running on a nvidia GTX 260. The monitor is a Dell 2407WFP-HC. I have had it plugged into other machines and windows sees it the same way. – Steven Lu Sep 18 '11 at 21:58
  • What refresh rate do you have it running at? I assume windows would probably autodetect 60Hz, but never hurts to check. Reason I ask is that the specs at support.dell.com/support/edocs/monitors/2407WFPH/en/about.htm say that 1920x1200 is only supported at 60Hz – camster342 Sep 18 '11 at 23:52

I know this is an older post but I had (almost) exactly the same issue - a monitor that was being detected at completely the wrong resolution, this turned out to be a problem with the EDID from the monitor.

I resolved the issue with the help of my graphics card settings which allowed me to override the reported info and use my own custom settings.

|improve this answer|||||
  • What graphics card? What settings did you change? – Simon Sheehan Oct 23 '11 at 17:03
  • 1
    I am currently using an ATI graphics card, so in catalyst control centre > my vga displays > properties (vga display) > untick use EDID, then set your resolution from the list below, hopefully the one your looking for is there. – David Craig Oct 23 '11 at 17:26
  • Updated Question. It's definitely an EDID issue: I know because the monitor prevented Linux boot-up! – Steven Lu Jul 29 '12 at 5:16
  • 1
    @PrivcateSniper: thank you so much for the tip. I could not get 1920x1200 for an Acer AL2416W monitor using integrated ATI Radeon HD 4200. I thought that I needed a video card, and was about to order one. I am so glad that I read your answer before making the mistake. – Hong Nov 17 '12 at 14:58
  • @Hong: NP dude :) – David Craig Nov 17 '12 at 20:46

I suspect a wrong setting.

1) First you can detect a missing row with a full screen test pattern:


enter image description here

2) Then you can analyze your system and adjust display parameters with advanced apps:

Warning: You can damage your video card and monitor with wrong settings.

enter image description here

|improve this answer|||||

The answer is 'yes'; it happened to you. I can assure you that this issue, or something of a similar nature, has happened to someone else, but they obviously don't frequent this forum or they've decided to remain silent about it. Nonetheless, as long as the question is left 'open' and no one responds in the affirmative, can you assume the answer is 'no'?

From a technical standpoint, which is the only interesting response, I would suspect a bad video card, and I'd suggest you try a different one, just to eliminate this possibility. I've seen much worse pixellation from seriously flawed cards and the erroneous resolution would almost have to be due to the card because the monitor could only suggest the 1920x1200 resolution since it doesn't have any special circuitry that recalculates it's resolution based on refresh rate or anything else. I would further guess that the card was damaged by overheating, if it's not a manufacturing flaw. Make sure the fan on the card is not obstructed by dust or not spinning at all. I'm assuming that you've already tried reinstalling the driver.

|improve this answer|||||
  • I am almost certain the issue does not lie with the computer. I have tried this monitor on many different computers and it gets detected this way in every case. – Steven Lu Sep 22 '11 at 5:34
  • I luve that, Yes it happened to you. :-) did you ever try and force the proper monitor driver into the "generic" location, using a driver update on it, and forcing the dell driver to be put there. (its not really a driver but more the parameters for the monitor). ALSO, winders update has put out a DELL port update for dell monitors, I have no idea what it does, or why it exists. it didnt change anything for my similar but older dell monitor. for its size it was probably a "monitor driver" and nothing else. – Psycogeek Sep 25 '11 at 3:45
  • You're correct - the monitor 'driver' isn't actually a driver at all, but merely a color spectrum table that establishes the range of colors, or color gamut, that the device can reproduce. – user98721 Sep 26 '11 at 5:07
  • 1
    (Oops, time limit) This new info helps establish that the problem is your monitor; now I'm thinking that the firmware may be corrupted, but I don't think you'll be able to do anything about this if true. The fact that the monitor can't be identified would also back up this theory. These issues aren't easy to diagnose without all the info up front. – user98721 Sep 26 '11 at 5:17
  • << it doesn't have any special circuitry that recalculates it's resolution based on refresh rate or anything else. >> This is actually exactly what I'm suspecting. – Steven Lu Oct 11 '11 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.