25

I have downloaded and installed a new theme before in my fedora machine.

However, I got this warning when I load gvim, nautilus every time.

(gvim:4629): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
(gvim:4629): Gtk-WARNING **: Unable to locate theme engine in module_path: "equinox",

How can I download this theme engine?? and remove this warning?

10

On Ubuntu 13.10 the command i needed was:

sudo apt-get install gtk2-engines-murrine:i386

I know the question is about fedora but I ended up here where one of the answers pointed me in the right direction.

Just in case it would be helpful to others.

1
  • works on 64 bit too
    – Lynob
    Jul 1 '14 at 11:30
9

If it's unable to find the engine, it means you haven't installed them yet. Simply do someting like this:

sudo yum install gtk2-engines gtk-murrine-engine gtk-equinox-engine
3
  • this is a correcter answer as the other one doesn't say anything about the murrine or equinox engine
    – DarkMukke
    Jan 26 '13 at 10:19
  • 1
    Packages are named gtk2-engines-murrine and gtk2-engines-equinox for some distributions. Apr 3 '13 at 21:53
  • 1
    it is "gtk2-engines-murrine" in ubuntu. Perhaps you should also consider installing "murrine-themes"
    – HongboZhu
    Dec 9 '13 at 9:16
9

Install gtk-engines package from your distro's repository. If there's not a gtk-engines package, search for a package with a similar name, you shall find one.

For ubuntu the package name is gtk2-engines. You may need to reinstall the package:

$ sudo apt-get install --reinstall gtk2-engines
4
  • I am using fedora, how can i Download that from distro? I am a linux new bie :(
    – Kit Ho
    Sep 20 '11 at 13:46
  • AFAIR, Fedora uses Yum to get packages, if so, try running "yum install gtk-engines" from your terminal.
    – MilanorTSW
    Sep 20 '11 at 14:40
  • Alternatively, try downloading an rpm package for your architecture from here: fr2.rpmfind.net/linux/rpm2html/search.php?query=gtk-engines and install it using "rpm -i <package-name>".
    – MilanorTSW
    Sep 20 '11 at 14:47
  • i reinstalled (with the mentioned command), and the error repeated. (i'm actually trying to run a Qt4 on Mint 17) Dec 21 '15 at 13:32
7

People experiencing this problem with, eg Acrobat Reader on 64bit installs should try this:

sudo apt-get install gkt2-murrine-engine:i386

2
  • could u elaborate Usage of gkt2murrine engine? Aug 30 '13 at 7:58
  • I've no idea what it does under the hood, just that Acrobat Reader complains if it's missing, and doesn't if it's present. There are accounts of problems with older versions of vmware-player requiring gtk2-murrine-engine as well. Sep 1 '13 at 2:15
2

If none of the other answers solved your problem, you can also try

sudo apt-get install libgtkmm-2.4-1c2a libgtkmm-2.4-dev

This worked for me (Ubuntu 14.04 x64, Gnome 3.12). I already had the gtk2-engines-murrine installed (both i386 and x64), and changing the GTK_MODULES didn't do anything for me.

1
  • Thank you. I had the exact same problem and this solution worked like charm
    – CHID
    Nov 1 '15 at 6:29
1

I installed sudo apt-get install libgtkmm-2.4-1c2a libgtkmm-2.4-dev But gives that error again.Then I download murrine-0.90.3.tar.gz and

tar -xvf murrine-0.90.3.tar.gz
cd murrine-0.90.3
./configure
make
make install

now works. no errors.hope this helps someone.

0

How about installing package gnome-themes-standard. Try sudo apt-get install gnome-themes-standard or similar command in the corresponding way depending on what linux package management used.

0

This worked for me: Using Synaptic, search for 'gnome-themes' As a side-effect that will also list an entry gtk2-engines So just install gtk2-engines, i.e. Mark for installation and Apply

0

For Ubuntu 20.04, it is sudo apt-get install murrine-themes to solve the warning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.