I am trying to install the Microsoft Visual Studio 11 Developer Preview on Windows Server 2008 R2. When it gets to the Microsoft.NET Framework 4 Multi-Targeting Pack package I get the following error:

The endpoint format is invalid

Clicking close (or Reboot Now) causes the installer to visually close, then I get a crash report 5-10 seconds later.

enter image description here

Any ideas how to fix this?

  • do you have a http proxy ? – Steve B Sep 20 '11 at 10:24
  • Nope no http proxy. – maxp Sep 20 '11 at 11:07

I ran into a similar problem just now. To fix it I clicked on the problems link. This opened a log file. I scrolled to the bottom and checked the last file to fail during installation. I deleted the folder of the offending file in "C:\ProgramData\Package Cache" and restarted the installation.

My installer than re-downloaded the file and proceeded as normal.

| improve this answer | |

Short answer: copy the installer to and back from a FAT file system before running it.

Long answer: Sometimes when one of the larger Microsoft installers is downloaded from the Internet on to a machine it's marked with security information in NTFS that prevents some operations that need to occur during the install from being performed.

| improve this answer | |
  • 4
    The better way to do what you're describing (which is removing the zone information) is to right-click the file, choose "Properties," and click the "Unblock" button (which will appear just below the "Advanced..." button. If the"Unblock" button isn't present, the file does not have zone information attached. – BillP3rd Sep 24 '11 at 19:13

If you're installing from the web, you might try installing locally from a CD. You can get the ISO image from here. You can then put it on a CD or use something similar to Virtual Clone Drive to mount the image.

| improve this answer | |

Try right-clicking the following MSIs, and choosing 'Repair':

\VS11_DP_CTP_ULT_ENU ISO\packages\NetFxDTP\NetFx_DTP.msi
\VS11_DP_CTP_ULT_ENU ISO\packages\NetFxDTP\NetFx45_DTP.msi

And then run the installer as 'administrator' (right-click, choose 'Run as administrator'):

\VS11_DP_CTP_ULT_ENU ISO\vs_ultimate.exe

I was getting the same error, and the above worked for me.

| improve this answer | |

If the problem is with the installation of .NET Framework 4, you might download the stand-alone package and install it yourself :

Microsoft .NET Framework 4 (Standalone Installer)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.