I have a client that has Internet Explorer 8 installed. There are some websites that are not displaying correctly, they are coming up with text only. Normally when this has come up, clearing the history has fixed the cache issue.

For some reason this has not fixed the display issue. I have removed and installed IE8 again, cleared all data in the 'Content.IE5' folders in their profile.

Signing onto the computer as myself displays the websites correctly, so it must be something in the local profile...

Any help would be greatly appreciated.

  • Do the 3 operations described here change anything : Why do some webpages look incorrect in Internet Explorer 9? ? – harrymc Sep 23 '11 at 6:08
  • the Woo, the IE9 seems to be more about Fixing Bugs, than about adding in more features (and bugs) would it be possible to upgrade these computer to 9? – Psycogeek Sep 23 '11 at 14:09
  • 1
    @TheWoo: Could you provide the addresses of some affected websites and some screenshots of the symptoms please? – James P Sep 26 '11 at 16:33
  • would be nice to see which web sites (paste links) are not working, and the types of text out put you are seeing. Pictures could help quite a bit. It could be the doc type declarations of the web sites are not being handled by the browser properly. A proxy server could be causing problems not letting certain types of request through. So many potential problems. We need more info. – nelaaro Sep 29 '11 at 8:19

Use applications like CCleaner to clean it and also remove any toolbars and see if it is working


Maybe the compatibility mode/view is enabled on one of the profiles, but not the other?

Do the sites display correctly in a standards complaint browser: Opera or Firefox?

  • But the problem is profile dependant, since when I sign on as myself the site displays correctly. – The Woo Sep 21 '11 at 2:30
  • @The Woo, IE Compatibility View is a user setting, check Tools > Compatibility View in the IE menu. Have you tried other browsers? – Hydaral Oct 7 '11 at 2:06

Check if you have disabled showing images (Internet options -> Advanced -> Multimedia -> Show Pictures).

You can also explore the HTML source or save it in a file and open it another browser to eliminate other factors.

Good luck.


Best thing to do is reset your internet explorer there's an option in the tools/internet options/advanced/restore advance settings and click the other one as well reset. Your other alternative would be using a different browswer it's always better to have 2-3 different browser to use anyways just incase if one get hijacked you don't want to be limited with one if one stops working you have other options. Best ones to get is google chrome and firefox.

hope that helps


We ran into this issue with a web application - it turns out that we were not properly setting the MIME types of the content files we were delivering (specifically, the external .css files). I'm not sure about IE8, but IE9 would not actually apply the css files if the .css file MIME type was not text/css.

Use Fiddler, IE9's Network tab, Firefox's Net tab, or any other HTTP request viewer to see the actual request and response for your .css and image files. This will let you check the MIME type, see if they're coming back with normal HTTP status codes (200 is normal, 304 is not altered since last requested - both are common here), and see how long and in what order the files are requested. If it isn't the MIME type, you may be able to figure out what is the issue.

EDIT: You mentioned it worked for you intermittently - I'd still recommend this method to ensure files are being downloaded properly, it could be a firewall or something else client side.

Not the answer you're looking for? Browse other questions tagged or ask your own question.