I have a Logitech diNovo keyboard which includes media buttons for play/pause, stop, next, previous. I would like to let those buttons control Spotify. I've tried to add Spotify to the players.ini file as described here, but I still cannot control Spotify - focused or not. Spotify does not show up the "Select Media Player" dropdown box in the SetPoint application:

enter image description here

Does anyone have Spotify properly configured for Logitech/SetPoint?

I'm running Windows 7 and SetPoint 4.80.103


The problem here is simple:
The SetPoint software provided by Logitech swallows all media-key-presses, and only pass them on to "verified" programs.

The solution is less simple:
1. Navigate to C:\ProgramData\Logishrd\SetPointP\Devices\Keyboard
2. Browse the subfolders until you find an XML containing the name of your keyboard (it will say something like DisplayName="Media Keyboard Elite")
3. Search for and comment out any <Button> entries that reference HandlerSet="MM ..." (there will also be comments for each entry with a description like <!-- Button Name => PLAY -->)
4. Restart SetPoint

This will keep SetPoint from swallowing the media-key-presses, leaving Windows to handle them as normal "multimedia keys".

  • In my case Spotify skipped two tracks when pressing "Previous" or "Next", and the Play/Pause button was useless, because it was duplicated as well. This solution worked for me.
    – gkerenyi
    Feb 19 '16 at 13:22

I know this is ages old now, so SetPoint is several versions on, but the instructions on this website seem to work, providing you also kill background windows media player processes.

The procedure to fix this is as follows:

  1. Close Logitech SetPoint by right-clicking the icon in the system tray.
  2. Open notepad as administrator (right click and Run as administrator).
  3. In notepad, open the file "C:\Program Files\Logitech\SetPointP\players.ini" (your folder may be named SetPoint instead of SetPointP on older versions or upgrades). (Hint: If you don't see the file, you must select "All Files" in the drop down that says "Text Documents)
  4. At the end of the section [Players], add the following line: spotify=wac,spotify.exe,SpotifyMainWindow,xxx,xxx,xxx,xxx,xxx,xxx,xxx,0,1,Spotify
  5. Save the file. (If this fails or the Save As dialog pops up, this is probably because you didn’t run notepad as admin. Since this is inside the Program Files directory, you need to be admin to edit.)
  6. Kill any processes belonging to other media players (especially wmp)
  7. Launch SetPoint again ("Mouse and Keyboard Settings" in the start menu or restart the system) and verify that the media keys now work better.
  • 1
    Just a note for someone else that may find this: My keys are able to control Google Music through an addon after I closed SetPoint. It did not work while SetPoint was open. This breaks all the other SetPoint keys while it is closed (zoom, window stack, calculator, etc.) Mar 13 '14 at 20:31

What I found, was that Chrome was eating my inputs. After restarting the HID service, I noticed as soon as I tabbed into chrome, the inputs would get swallowed up again.

Turns out: Google Play Music caused it. Just uninstall Google Play music (Type chrome://apps in your browser, right click => Uninstall), and you should be good to go.

  • The fix for me was similar. I had to remove YouTube from Chrome Apps (chrome://apps) and Spotify started working again with my media buttons.
    – kindagonzo
    Feb 3 '20 at 19:32
  • Wow been looking for a solution for months, this solved my issue with my logitech wireless keyboard and my logitech MX keys. Thank you
    – ccrez
    Jul 20 '20 at 5:03

This is obviously way past the question date, but it might be helpful to others with the same issue:

Similar to Austyn's comment on the other answer, SetPoint does indeed break media keys for Google Chrome web apps. Closing the application entirely might not be the best solution for you though.

Note: Although the media keys (incl. volume) will then work for any program, the other function keys will not as they rely on the SetPoint Driver.

Steps I took to fix the media keys:

  1. Open the Start Menu (Windows 7) or Unified Search (top right corner in Windows 8)
  2. Type "Device Manager"
  3. Open "Keyboards" from the list - you should see a Logitech Keyboard there
  4. Double click this item (or right click -> properties)
  5. Click "Roll Back Driver"

What this does is essentially reset it back to the original Windows Driver. As I said, this will break your other function keys. For me, that wasn't a problem because I didn't use them. Because we only disabled the keyboard driver, the mouse driver will still integrate with SetPoint in case you use other buttons on your mouse.

Google Music & other web apps are now easily controlled with the media buttons!

I'm using a DiNovo Cordless Desktop setup.

Not the answer you're looking for? Browse other questions tagged or ask your own question.