I'm experiencing the same issue as this question, which seems to be unresolved. I'll provide more detail, sot that this qualifies as a better representation of the issue. It all started after moving to a new service provider. It also may be tied to Windows Updates.

What is my setup?

  • Windows 7 64-bit. Plenty of power under the hood, no driver updates so assuming hardware isn't the cause.

What happens?

  • Javascript files are not loaded. By this, I mean on a page the Javascript works, but any referenced Javascript files will not load in ANY browser. Cross-domain or even the same domain. And again, I have tried all browsers...

What have I tried?

  • Reboot between about every step. Shutdown often as well, as this has been a 2 week issue.
  • I already had Chrome and IE9 installed. I tried using all 3 (IE has a 64-bit option, making it three)
  • Made sure no proxies enabled.
  • Cleared cache, cookies, all temp files I could find. Issue persists.
  • Cleared DNS (ipconfig -flushdns). Issue persists.
  • Setup Google Public DNS in router. Also release/renew in router.
  • Tried Windows Update, however, it gives an error. I will try to get error later. Microsoft site says Windows Update might be corrupted (if you get that error), so I followed the instructions on their site to create a new Windows update folder. Issue persists.
  • Ran Malwarebytes Anti-Malware, no issues. (updated first)
  • Full scan of MS Security Essentials. No issues found. (updated first)
  • Uninstalled MS Security Essentials, same issue persists.
  • I uninstalled Chrome, and installed FF6. Same issue.
  • Reset IE, ensured 3rd party extensions disabled. Issue persists.
  • Checked HOST file, it looks normal and hasn't been modified in a while.
  • Desperation caused me to attempt a System Restore. Sadly, it could only go back a couple days. It was successful in restoring, but failed to fix issue.
  • Ran a sfc -scannow. Found nothing, issue persisted.
  • Using Firebug for Chrome, specifically saw that it was loading on page javascript but not loading any linked JS files. Seems to load linked CSS fine.
  • Found another site that mentioned this might be caused by windows updates. I have began uninstalling windows updates, and am back to mid august. Several more to go, so far haven't found any that have fixed it.

I may have missed a step or two I've done, as this has been going on for at least 2 weeks.

What else can I do to troubleshoot this issue and get an understanding of what's happening?

  • 7
    Just so others know: This is how you write a good troubleshooting question. – slhck Sep 21 '11 at 19:32
  • Instead of uninstalling updates one or two at a time, perhaps try Windows' System Restore to revert to a point in time where it DID work, and see if it works again or not? You've tried more than one web page/site in testing correct? – Ƭᴇcʜιᴇ007 Sep 21 '11 at 19:32
  • @techie007, I did a restore as far back as I had one. I generally do not keep that feature on however, so it was not but a few days prior to me 'noticing' the issue and didn't fix it. – JClaspill Sep 21 '11 at 20:52
  • @jmreicha I plan to try that tonight. I had thought it was perhaps a dns issue with the router, after switching ISPs, but since I can load sites fine (even the js file directly if I copy/paste in address bar), I'm thinking that is a long shot as well. – JClaspill Sep 21 '11 at 20:53
  • @slhck Thanks. I've been doing this type of stuff for so long I know I needed to go all out. I know I should probably fold my cards and just format... but I really don't want to go through the hassle. I think in the end, I'm going to have wasted more time trying to fix it than if I had just formatted. :) – JClaspill Sep 21 '11 at 20:54

This is way out there but have you tried connecting directly into your modem and removing your router as a possible source of problems?

I stumbled on this recently when I was randomly unable to install windows updates from their website. It didn't even occur to me to rule out the router originally as web pages were loading fine.

It just so happened that I was planning on replacing the router anyway. After the swap I noticed I wasn't having the problem any more so I began suspecting the old router as a problem. Sure enough I plugged it back in and after awhile I would experience strange (but non reproducible) errors.

Glad to see you figured it out!

  • 1
    This was it! The problem was the router proxy/DNS settings(DDWRT). I removed all enabled options for DNS and proxy, and it instantly started working. The reason I hadn't thought to try this before is that this is an old router that I had 'reset' prior to putting in line. I moved to a new ISP/house, put on the new router, and never thought twice about it. – JClaspill Sep 22 '11 at 16:41
  • I had the same problem. It turns out that I probably had some corrupted settings in my DDWRT flashed router. Simply changing anything in the "Access Restrictions" tab in any way caused this problem to happen - no .js files would load on any PC in the house, any browser, even telnet, period. Restored an old router backup and all was well. Then tried disabling a profile in Acess Restrictions and suddenly no .js files would load again. A wild guess is that my nvram overflowed and corrupted some things, the Asus RT-N16 router doesn't have much memory and that is a common problem. – Eric Sassaman Jan 26 '16 at 8:28

When troubleshooting an issue like this you need to check everything from end-to-end:

  1. Make a back-up if you haven't done already, you might lose personal data otherwise...

  2. Get troubleshooting tools that show you what happen under the hood:

    • Fiddler2, a web debugging proxy, allowing you to see what happens to the requests.

    • Wireshark, to go to level of packets to figure out whether there is something odd there.

  3. Do a complete manual reset of Internet Explorer including any personal data or settings.

  4. Start Fiddler2.

    Identify what happens with the Javascript request, surf cache-less to http://superuser.com.

    In my case, I got return code 200, which according to RFC 2616 - HTTP/1.1 stands for OK.

    Now, in your case I suspect two things might be seen here:

    • The request might not happen, because:

      • The source code of the web page has been modified not to download the .js file.

      • The browser is not allowed to request the .js file, by means of a local firewall.

    • The request did happen and get a 200 OK response, but the body is invalid.

      You can see the body by clicking the .js event and then clicking the body tab in the bottom right section, here you should see Javascript like code. If not, something's tampering with it...

    • You get a return code indicating the problem.

    The exact thing that happens here would give us a direction to search for...

    If you have suspect packet level problems, fire up Wireshark if you know what you're doing.

  5. If you have it, use a LiveCD or another computer/installation to verify if it's happening there.

  6. Confirm that other users of the same ISP in your neighbor as well as people in your appartment have no problem, it's important that you need to know that it's-just-me-and-nobody-else before you continue doing work on your end of the connection.

  7. Ask your ISP to reconfigure your modem, just to ensure the problem is not there.

  8. If you host your a router with a firmware like Tomato or DD-WRT, check it's configuration.

  9. Disable any firewall (router, software, windows firewall) to pinpoint whether a firewall is the issue.

  10. Disable any virus scanner (also spyware, ad-ware, defender) to pinpoint whether they are the issue.

  11. Make sure your computer is up-to-date (Windows, Drivers, ...), also check for third-party code:

    • Automatic Runs, look for non-Microsoft things that are starting, especially network related ones.

    • Process Explorer, look for non-Microsoft things that are running, use the Company Name field.

      If you know what you are doing, you might also check out the DLLs.

    • Go to the settings of your network card, look at what items are being used.

      enter image description here

    • In the Device Manager, check the lower/upper filters in the details tab of your card's properties.

  12. Reset your network settings.

    Execute the following commands, put them in a .bat file and run it as administrator:

    netsh winsock reset all
    netsh int 6to4 reset all
    netsh int ipv4 reset all
    netsh int ipv6 reset all
    netsh int httpstunnel reset all
    netsh int isatap reset all
    netsh int portproxy reset all
    netsh int tcp reset all
    netsh int teredo reset all
    ipconfig /flushdns
    ipconfig /release
    ipconfig /release6
    ipconfig /renew
    ipconfig /renew6
    ipconfig /registerdns
  13. Check for tampering to your network settings.

    Similarly, execute

    netsh dump > "%HOMEPATH%\My Documents\netsh dump.txt"
    ipconfig /allcompartments /all > "%HOMEPATH%\My Documents\ipconfig dump.txt"
    route print > "%HOMEPATH%\My Documents\route dump.txt"

    and inspect the dump files in My Documents.

  14. Try creating a new user profile, in some very odd occasions it actually works.

  15. Abandon ship! It seems you can't use it where you live. Don't worry, Google is working on Dart...

But, lessons learned...

Proper back-ups are invaluable and the easiest fix to this kind of problem!

Well, if your ISP or Apartment is not trying to fool you in a nerdy way.

  • 1
    Excellent suggestions! +1 for depth. The issue turned out to be a proxy/dns setting in the router. DDWRT firmware, but the issue is now resolved. Thank you for taking the time to put all those great suggestions together. – JClaspill Sep 22 '11 at 0:56

Did you make sure that you had installed all of the latest updates and patches from MS? This may have been an issue that MS resolved in a security/critical update or patch so I would make sure to get Windows fully updated.

  • 2
  • "Javascript files are not loaded in ANY browser. By this, I mean on PAGE javascript works, but no referenced files will load." – user1686 Sep 21 '11 at 19:50
  • I can't install updates. And as for JAVA, this issue is not due to JAVA, and is simply related to javascript files. Even javascript works, just not linked files. But yes, I do have the new java update. If anyone else asks. – JClaspill Sep 21 '11 at 20:51
  • Wouldn't matter. Java and JavaScript have virtually nothing to do with each other aside from the first 4 letters in the name. – BBlake Sep 21 '11 at 21:10
  • My mistake, I apologize. I retract my comments. However, the fact that you cannot install MS updates seems like a big indicator that there is an issue with Windows. Once you resolve that issue, your browser issues will likely be sorted out as well. Do you have the latest Service Pack installed? If not you should try installing it. Otherwise, you should try a repair/upgrade install of Windows. – Dan Sep 21 '11 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.