I've had two 1280x1024 monitors running for years on an nVidia 8800GT card with no problems. I've now replaced one monitor with a new 2560x1440 one. The card seems to support both fine, however every time I reboot the resolutions and monitor positions revert to the old settings. I've tried upgrading, downgrading, stripping out and reinstalling many versions of the nvidia drivers to no avail.

Logging in as another user doesn't help - same problem. Booting into another another OS (Win7 64) works OK, so it is just this OS installation. During boot up everything looks fine (ie native 2450x1440 res) until the nVidia control panel or something is loaded which flips it back into the old mode. I have no old saved nvidia profiles. I can't find anything in the registry relating to these old settings.

Its driving me crazy having to set resolutions and realign monitors on every reboot! Can anybody help?


I was this close to writing my own proggie to deal with this annoyance (My dual display is at work, and DisplayChanger costs USD 500 for commercial use!).

Then I read a tip here that saved me from my misery.

Do (did) you use Windows LiveMesh?

That's your culprit right there.

Disable the service named "Windows Live Mesh remote connections service" and prepare to reap the benefits next time you reboot.

Or uninstall LiveMesh altogether, it's been discontinued in Feburary 2013 anyway.

| improve this answer | |
  • Woohoo! Finally something that works! Many thanks for coming back here and posting that answer. I found the service (wlcrasvc), but just uninstalled Live Mesh from Windows Live Essentials 2011 and that did the trick. Thanks again. – SoftDeveloper Apr 30 '13 at 13:27
  • That's pretty much how I felt when I tried it :) I thought I'd pay it forward. – Cristian Diaconescu Apr 30 '13 at 15:09

I also had this problem (NVidia GTX570) when I updated the driver. I have two monitors, a Dell 2209WA and a Cintiq 12WX). Position, resolution (and my primary monitor selection) was lost every reboot, which sure is annoying.

For some reason the scaling settings "Desktop size and position" was set to "Full screen" in the Nvidia control panel, which seems to cause the problem. I changed this to "No scaling", and setting up each monitor to it's native resolution. No more problems after this!

| improve this answer | |
  • Thanks for the suggestion, but it didn't help me. With "No scaling" the wrong resolution is still set, but it just comes up in the centre of the screen with black bars all round instead of stretched. For some reason it seems to be setting monitor 1 to the same resolution as monitor 2 instead of its native resolution. – SoftDeveloper Sep 12 '12 at 15:57

I have this problem as well. I found a hotfix which is supposed to fix this issue: http://support.microsoft.com/kb/2496400

Unfortunately it didn't help for me.

| improve this answer | |
  • Thanks, I tried it but it did nothing for me either. I think it is a problem with the nVidia control panel or drivers. – SoftDeveloper Jan 12 '12 at 10:00

As requested by shufler, I am 'answering' my own question, well, it's a workaround anyway.

Basically, I think the nVidia control panel (or something) sets the resolution to some old values hidden somewhere (couldn't find them in the registry) towards the end of boot up but before log in. Removing the nVidia drivers, control panel, settings files, and registry settings (even using nVidia's own tools) does not fix the problem.

The workaround is just to automatically reset the res and positions to what you want after log in. I used the command line Display Changer utility to do this in a batch file which runs at start-up:

timeout 2
"C:\Program Files\12noon Display Changer\dccmd.exe" -max -more 
"C:\Program Files\12noon Display Changer\dccmd.exe" -monitor="\\.\DISPLAY2" -ty=416 -apply

The 2s timeout allows time for other stuff to load on boot up otherwise it doesn't always work YMMV. The first line sets the primary display monitor to its max resolution and waits for another command, the second line positions the y pos of the second monitor 416 pixels below the top of the first and applies both commands. See the display changer documentation for more info, most people will probably just need the first line with the -max setting.

Hope this helps somebody. If anybody figures out a proper fix please let me know.

| improve this answer | |
  • I have got rid of this workaround now as Cristi's answer (getting rid of Live Mesh) solved the problem. – SoftDeveloper Apr 30 '13 at 13:35

I also had this issue with the Windows 7 update.
Resolution steps:

  1. Uninstalled and reinstalled the software and driver for the monitor adaptor (DUALHEAD2GO - Digital SE) - same issue
  2. Hotfix offered from Microsoft - after reboot, same issue. (http://support.microsoft.com/kb/2496400 - hotfix website link)
  3. Finally, I ended up updating the Display Adapters following these stpes: a) go to Control Panel> Device Manager b) in the "Device Manager" pop-up window c) right-click on "Display adapters" d) click on "Scan for hardware changes" After this, the computer "fixed" itself.

I'm not exactly sure if it was the combo of everything or if just the last thing helped, but, just thought I'd add this info, just in case :) hope it helps! :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.