17

In OS X, from Lion onwards, when I click on some of my folders in Finder and the title row of the files contains the usual stuff like "Date Modified" and "Size". However unlike the old Finder view I can't click on them to sort. Why is that and how do I make it never show up ever again?

enter image description here

30

Make sure "None" is selected in the sorting options menu - else you have the behavior you described.

enter image description here

3
  • 4
    Found this confusing, too. "Arrange by" and "sort by" are almost synonymous -- it feels broken when they're actually mutually exclusive states.
    – emcmanus
    May 10 '12 at 3:44
  • It's awful. I created a new folder that was sortable just fine. I then created a subfolder that had this "feature". Sep 18 '12 at 22:44
  • Damn Apple. I write programs that can sort within grouping, why can't they?!? "It just works?" Hardly. Anyway, thanks @Vervious for the answer to my Apple-induced frustration for the day. +1 Apr 11 '13 at 22:11
3

Check out In OS X Lion, Finder will not "Arrange..." from Apple Support Communities.

You'll find how to solve that problem:

There seem to be a few glitches in the Arrange/sort model. You can actually Arrange by and Sort By separately. You can get to the Sort options by holding down the Option key while selecting the Arrangement button.

However, there aren't any sort options when you Arrange by Name. And it doesn't change the sort by option when you switch to Arrange by Name.

Try setting the Arrange by to None. Then, hold down the option key and press the Arrange button. What is it sorted by?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.