I am running Ubuntu for a week and since a few days it is no longer able to properly shut down the computer.


enter image description here

enter image description here

I have tried booting the old kernel and using the terminal (sudo shutdown -h now, sudo reboot) to shut down the computer, but to no luck.

  • Check all scripts run in the shutdown process for anything that looks like it would spawn an interactive shell. The "Userspace bootsplash" seems like a good start.
    – user1686
    Sep 26, 2011 at 7:38

1 Answer 1


Something is FUBAR in the startup/shutdown scripts. You could restore them using a simple Ubuntu live disk. Or just reinstall the system, and re-attach your home directory at install. (So your stuff won't "disappear".)

  • Yes, but that makes it my last Ubuntu experience (last year) all over again. In the 2 weeks I used Ubuntu, I had to reinstall the entire system twice and that's what people used as argument against Windows: Ubuntu doesn't require to reinstall. Also, I don't like the term FUBAR: It means just giving up and not learning.
    – ujjain
    Sep 25, 2011 at 13:58
  • Oh I very much tried back then. Like when I had to read my mails and Arch Linux refused to do so. I spent 4 hours, fixing things, so I can read my mail, and turn off my computer. I'm not saying you have to reinstall ... it's an easier alternative, a less time consuming one, that is. You CAN check your /etc/rc.*/ init scripts, diff them ( to the ones on the disc / .debs ) and then fix them by hand. It's just ... I jumped into an assumption, that you don't want to waste your time. :)
    – Apache
    Sep 25, 2011 at 21:50
  • Also, check IRC when you encounter such a problem. We help here ... on SU, we try to do so. But getting help real-time on the #Ubuntu channel for example, is much faster. (Or get on the SU chat when it happens next time.)
    – Apache
    Sep 25, 2011 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.