I installed the nvidia driver directly from the nvidia website. Installation went ok, but after reboot, Ubuntu logo appears fine, but when entering login, I hear Ubuntu startup sound, but the screen keeps black/blank.

Does anyone know what it is? I'm very tired, as long as I tried many things and nothing works.

I'm at a Ubuntu 11.04 Natty Warhal box.



NVidia driver module:

NVIDIA UNIX x86 Kernel Module 280.13

VGA card:

GeForce GT540M CUDA

$ lspci -v | grep -B10 nv

01:00.0 VGA compatible controller: nVidia Corporation Device 0df4 (rev a1) (prog-if 00 [VGA controller]) Subsystem: ASUSTeK Computer Inc. Device 1642 Flags: bus master, fast devsel, latency 0, IRQ 16 Memory at db000000 (32-bit, non-prefetchable) [size=16M] Memory at c0000000 (64-bit, prefetchable) [size=256M] Memory at d0000000 (64-bit, prefetchable) [size=32M] I/O ports at d000 [size=128] Expansion ROM at dc000000 [disabled] [size=512K] Capabilities:

Kernel driver in use: nvidia
Kernel modules: nvidia, nouveau, nvidiafb

Here is my xorg.conf:

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "Monitor"
    Identifier     "monitor0"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Modeline "1368x768_60.10"  86.00  1368 1440 1584 1800  768 769 772 795  -HSync +Vsync

Section "Device"
    Identifier     "card0"
    Driver         "nvidia"
    BusID          "PCI:1:0:0"

Section "Screen"
    Identifier     "screen0"
    Device         "card0"
    Monitor        "monitor0"
    DefaultDepth    24
    Option         "UseDisplayDevice" "DFP"
    SubSection     "Display"
        Depth       24
        Modes      "1366x768_60.00"

I cant see any errors on my Xorg.0.log file.

Also on my blacklist:

$ cat /etc/modprobe.d/nvidia-installer-disable-nouveau.conf 
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

Worth to note that I have an Intel onboard video card installed apart from the dedicated nvidia one.

Any insights?

  • Question - have you tried plugging a monitor into the intel devices output? ALthough your Xorg.conf does not configure it, your Xorg.log seems to show this was the one used. Commented Sep 25, 2011 at 20:09
  • Yes, i have already tried and it indeed works. But my goal is to make my nvidia card work with Ubuntu. It's kinda disappointing to have a good card, and are unable to use it.
    – kaneda
    Commented Sep 26, 2011 at 17:26
  • The log doesn't actually show the nvidia driver being loaded - it has already started on the internal card - hence a blank output on the other. Are you sure the xorg conf is even being read/used? Commented Sep 27, 2011 at 19:42
  • You are right. I think that log is pasted wrong (I was changing things all over from time to time...). Sorry for that. Actually, I think I found an answer, which is not exactly good... I will post an answer to my question.
    – kaneda
    Commented Sep 28, 2011 at 6:28

2 Answers 2


I will post an answer to my question, so that it stays more visible to anyone who are interested.

Fact is, my laptop has a hybrid VGA configurations (nvidia and intel), and seems that there is still not a support for hybrid linux systems from nvidia. It's something related to nVidia Optimus Technology.

What I could understand so far is that it works this way: the desktop launches and is supported by the low-end Intel card. Also the monitor is attached to intel. So far ok, until some app demands 3D acceleration. In case when nVidia card is requested. What would normally happens is that the framebuffer on nVidia is copied to intels and then shown on monitor's display. On linux though, this mechanism fails and the cards cant work together, so the screen gets blank.

There is a partial workaround, called Bumblebee. Please follow this link.

  • users are encouraged to post solutions to their own question ,you can even mark it as accepted answer if you find it the most fitting of all the acceptable solutions.
    – Shekhar
    Commented Sep 28, 2011 at 11:34

Try running gksu nvidia-settings - this should configure your nvidia card, generate the configuration and ensure Xorg uses it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .