1

I have Excel attachments emailed to me daily.

When I open the attachment, it opens in Excel Viewer instead of in Excel.

I do have Excel installed.

This only happens with my Excel attachments from Outlook.

migrated from stackoverflow.com Sep 26 '11 at 8:03

This question came from our site for professional and enthusiast programmers.

  • Right click on one of the attachments, and see if there's an "open with" option. – Gilbert Le Blanc Apr 7 '11 at 18:48
  • 1
    or uninstall Excel Viewer :) never heard of it before. it might also help if you have normal Excel already open. helps me sometimes so that I dont have to wait for 10 addins to load – Bek Raupov Apr 8 '11 at 8:31
  • When you open an Excel file from Windows Explorer (e.g. by double clikcing on it), what does it open with? Excel or Excel viewer? – paulmorriss Apr 8 '11 at 13:33
4

As paulmorriss pointed out, you should tell us what happens when you open a file from the Windows Explorer.
Yet, I've never seen an option where Outlook would open files with another program than the Windows Explorer.

Here is what you (or whoever has the same problem) can try:

  • save your file to your Desktop
  • hold SHIFT while right-clicking the file
  • from the Open With list, select Choose Program and select Excel
  • make sure that you also check the box Use this program as the default

The next time you open such a file type, it should open directly with that program (even from Outlook).
If you still have this issue, tell us your version of Windows and eventually Excel.

1

If this is a custom operating system as in a government department installed but reduced version of windows due to the many security issues with all the versions. Then you might have to look at creating a macro that dumps the file in your outlook to a shared drive that you can access from any computer on your network. I had to do this once. You need to make sure that it leaves a "virtual path link" to the attachment and drive in question in html format. If you do not want to do this then.

You might want to

  1. remove the viewer software
  2. repair/reinstall your version of ms office you are running
  3. make sure that you are allowed to make these changes to the system you are on
  4. If all previous are unavailable to you as options then try the assign default file types
  5. check with IT admin to make sure its ok for you to build VBA to dump these files to a network drive.

If you do go with the option to dump the files you will see a good speed increase in your outlook. Here is a good example of this

0

Assigning File Extensions to Programs

  • Click on your Start Menu. In the search bar type "Default Programs" and hit enter.
  • The second option should be "Associate a file type or protocol with a program".

Microsoft Excel's most common file extensions are .xls, .xlsx, .xlm, and .xlsm.


  • Scroll down toward the bottom where you will find the above mentioned extensions.
  • Select the extension you wish to assign to Excel.
  • In the upper right area of the window select "Change program".
  • Select Microsoft Excel from the list of programs.
  • Hit OK

If Microsoft Excel is not in the list of programs to choose from, select "Browse" and rows to the install folder of Microsoft Excel and select the program from there.

For example: C:\Program Files (x86)\Microsoft Office\Office14


This Method will allow you to assign any file type to the Application/Program of your choice.

0

I also use outlook in my office and same happens. But, you can double click on the file or select it and press ENTER or right click and select Open With option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy