0

I have installed VirtualBox on Ubuntu 11.04. I launched it from the console and added a virtual Windows XP. Everything was working okay, but when I added VirtualBox as a shortcut to my menu it opens without this Windows virtual machine.

Why is this and how would I change the shortcut so I can see my VM?

5
  • How did you start it from the console exactly? Which commands did you type? Were you logged in as another user when you did so?
    – slhck
    Sep 26, 2011 at 11:21
  • I have just type virtualbox Sep 26, 2011 at 12:02
  • Quick test. When you open a fresh new terminal and enter sudo virtualbox, do you see your VM there? Now, if you enter just virtualbox, are they gone now?
    – slhck
    Sep 26, 2011 at 12:04
  • Yest VM is there when I open new terminal Sep 26, 2011 at 12:05
  • yes XP is there Sep 26, 2011 at 12:07

2 Answers 2

2

You configured your VirtualBox installation as the wrong user, i.e. root. You were probably starting VirtualBox with sudo virtualbox and therefore your whole configuration was written to /root/.VirtualBox instead of /home/your-username/.VirtualBox.


  • First, stop all instances of VirtualBox.
  • According to VirtualBox 4.0 documentation, you should find your VM in root's home folder, which we'll open with this command:

    gksudo nautilus /root/VirtualBox\ VMs &
    
  • Here, you should see a directory for the Windows VM. Take that directory, and copy it to /home/your-username/VirtualBox VMs. Close the Nautilus window.

  • Then, take ownership of this folder again. Might not be necessary, but doesn't hurt.

    sudo chown -R your-username /home/your-username/VirtualBox\ VMs/
    
  • Now, restart VirtualBox over the normal menu shortcut or by running virtualbox from the Terminal. Are you able see your VM now?

3
  • It didn't help, still I cant see my XP Sep 26, 2011 at 12:54
  • Does your /home/your-username/VirtualBox VMs folder now contain the Windows machine? Are you the owner of said folder (by looking at its permissions)? You could also try to set up a new VM and choose the .vdi file that is now in your home folder as the disk.
    – slhck
    Sep 26, 2011 at 13:10
  • I tried to export from root and import on my acount by there was some errors, so I decied to reinstall XP on this acount. Thanks for helping Sep 26, 2011 at 13:42
0

This can happen when you install the VM as an user different from the one you used to launch VirtualBox. This happened to me when I had used vagrant to create my VMs as user X, and then tried to check the VM installation status on VirtualBox as user Y.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.