I have a Core 2 Quad Q6600 (2.40 GHz) with core voltage 1.200 V (if it helps), on the motherboard Asus P5KPL-CM. So today, when I started my computer, it suddenly showed me that the CPU temperature is too high.

I checked it in BIOS, and it shows there that the temperature is around 98 °C. When I got into Windows, and checked the temperature with a few programs, they showed me 75-80 °C. I checked the speed of the fan using SpeedFan program, and it showed me that the speed of the "problematic" fan is actually 49%. So I lifted it up to 100%. And then, the temperature dropped to 71-81 °C (still high though). But after every restart, the speed of the fan goes back to 49%. So what's the problem? And why does the speed always reset?

2 Answers 2


These temperature measurements are not always exact, and there are many subtle errors that may produce quite strange readings. Why don't you first check by just looking into the machine (does the CPU fan run? Is the heatsink full of dust?) and touching the heatsink to assess whether that value is even possible?

If it is, check your BIOS settings. Fan speeds are generally set there somewhere. SpeedFan is a Windows program, so it gains control only after the one (or more) minutes spent booting.

Edit: According to the manual, you should find this setting under the BIOS' "Power" tab. As always with ASUS, its naming is completely intuitive and self-explanatory: "CPU Q-Fan Control". They build great hardware, but those BIOSes... but I digress ;-)

  • Thanks for your response, however, it turns out that the fan was actually displaced a little after some repair works done a day before. When I pressed it, the temperature has dropped to a normal level (around 60C). That's it :-).
    – gfgfgfg
    Sep 26, 2011 at 18:19

The fan speed is up to the motherboard, so see if there are any settings in the BIOS you can change. Failing that, you will need to contact Asus technical support.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .