9

I mistakenly mapped my P: drive in Windows 7 to a useless network share, and for the life of me I can't remove the network drive. It was set to "reconnect at login" and it seems impossible to remove. I've tried all solutions posted at this similar question but none have worked after reboot.

I've tried:

  • "Disconnect" from the right click menu in Computer (this worked for other mapped drives, not for this one)

  • Disconnecting the drive and remapping a drive to that letter with the "reconnect at login" option disabled. On restart the original drive reappeared.

  • net use /d z: deletes the drive but it comes back at login.

  • net use z: \\server\path /persistent:no was another suggestion, I tried deleting the drive with the above command, then remapped it using this command, didn't work. I think this is the same operation.

  • net use z: /d /y

  • reg delete HKCU\Network\Z /f Turns out this key doesn't exist, there is no P in my HKEY_CURRENTUSER\NETWORK\ key. But the drive still merrily shows up every reboot.

What else could cause this drive to keep showing up and how can I get rid of it?

Update: When booting in safe mode with networking the bad drive doesn't appear at all, though my other network drives do. Rebooting back to normal mode the drive is back as usual.

The drive does not show up for users other than myself.

6
  • 1
    net use /delete P: should work, you may want to try it booted up in safe mode.
    – N4TKD
    Sep 26 '11 at 19:13
  • @JohnDR I tried it in safe mode, the drive doesn't even appear in safe mode (with networking) though all my other network drives appear. net use /delete obviously didn't work as the drive didn't exist, but after a reboot it's back. I don't know where the mapping is stored since it's not in HKEY_CURRENT_USER...
    – Ben Brocka
    Sep 26 '11 at 19:31
  • Have you tried mapping another folder(resource) to the drive letter P?
    – N4TKD
    Sep 26 '11 at 20:03
  • Yes, I've removed P and replaced it with another folder, works until restart, at which point it turns back to the junk folder. I also tried mapping it to another folder and disconnecting it while it's the other folder; at restart it's always back to the junk folder.
    – Ben Brocka
    Sep 26 '11 at 20:21
  • One last shot try "NET USE * /DELETE /Y" which wipe all persistent drive maps make sure you use caps.
    – N4TKD
    Sep 26 '11 at 21:26
2

Try searching your registry for the share name.

Do you have anything in the Startup folder?

There are multiple places where Windows looks to execute programs during startup - take a look at this http://www.bleepingcomputer.com/tutorials/windows-program-automatic-startup-locations/

5
  • Thanks for the tip, found reference to it in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Map Network Drive MRU, deleted the corresponding key...the drive is still there though. I don't have much on start up that would do anything like that, I'm looking at the Offline Files Sync thing to see if it might be doing it though.
    – Ben Brocka
    Sep 26 '11 at 19:45
  • What happens if you logon to the computer under a different account?
    – bryan
    Sep 26 '11 at 19:48
  • no network drives at all, which is correct for that user.
    – Ben Brocka
    Sep 26 '11 at 19:54
  • last resort - add a batch file to your startup to delete the mapping :(
    – bryan
    Sep 26 '11 at 20:47
  • Seems like there is some script or command issued at startup (at user logon) that maps the drive. That's what I would look for.
    – pbies
    Jun 5 '19 at 14:46
1

In my case, the mapped drive was an NFS mapped drive. I ultimately had to delete them from the registry, under HKEY_CURRENT_USER\Network.

0

I know this thread is very old, but the one thing I did not see in the discussion regards the user object in the directory where the P: drive could be set as the users home directory and mapped on logon, assuming the user is a Domain user, you'll find this setting on the profile Tab of the user object, clear the fields and your GTG.

Best of luck.

0

A very similar thing happened to me with VirtualBox folder shares. It turns out that if you manually map network drives using the usual way, but also check "auto mount" in the VirtualBox settings GUI, the drive will be mapped twice, both to the letter you picked in windows and to the last available letter (Z) available at boot. This is easily fixed by disabling auto mount in the VM settings.

Maybe, if not related to VirtualBox, you have a similar problem where an application is forcing to map the drive at boot. Try disabling possible culprits and see if that fixes the problem.

0

Okay for everyone having this issue whether it is Windows 7 or 10 or any other version of windows and have tried the net use commands along with registry deletes and the drive reappears I can tell you what the issue is, however its up to you to find it specifically. The reason it keeps reappearing is due to a application you have installed that reads from that mounted drive. For example in my case at the time it was a software called "Everything" which is basically a harddrive index searching software and in it I had the saved mounted drive as one of the drives I was reading from.

Now how does this help you.....firstly check which applications start with your machine ie. dropbox, antivirus, some gaming software, a gamebox every single application that is not ran by the system and auto starts with your machine. Now try to check each of them and ensure none of them are reading from the mounted drive with the issue, this should resolve your problem after you have found the specific one.

Have a great day all, hope this helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.