3

When I try to install Matlab 2011a, I get an error like this.

/tmp/mathworks_3203/java/jre/glnxa64/jre/bin/java: Permission denied

I searched internet, but what I found is to become root. I tried becoming root as

sudo su

However, result did not change. I guess, it is related somehow with superuser and privileges stuff, but nothing worked for me, any ideas?

2
  • Do you have a 32-bit or 64-bit installation of Ubuntu? In what form did you get Matlab (e.g. a CD? a zip? how did you download it, copy the files, extract it?) – Gilles 'SO- stop being evil' Sep 26 '11 at 23:40
  • Please note that sudo -s is a nicer way to start a root shell than sudo su. – sarnold Sep 26 '11 at 23:49
2

make sure the file /jre/glnxa64/jre/bin/java (inside your original matlab installation folder) is chmod 755.

4
  • I put the folder, it still gives the same error. – Ares Sep 26 '11 at 19:48
  • not the '/tmp/mathworks_3203/java/jre/glnxa64/jre/bin/java' file, but the corresponding file in your original matlab installation folder. – memyself Sep 26 '11 at 19:49
  • I put the corresponding file. – Ares Sep 26 '11 at 20:04
  • 1
    @Ares, what does it mean to "put" a folder or file? Give commands and ls -l output. – sarnold Sep 26 '11 at 23:48
0

I had the same problem. Apparently a problem related to extracting the information from the ISO (I cannot explain how): http://www.mathworks.se/support/solutions/en/data/1-DHWZAO/

I solved it by installing Furius Iso Mount and mounting the .iso instead of extracting its contents. Then sudo-run the install script as usual. Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy