0

I am ssh'd into a remote box, I think it is redhat, but I am not sure how to tell. In my home directory I went through the process of installing screen and all its dependencies from source as it is not already installed.

I can run screen, and it opens fine and gives me a prompt, however any command from ls, to vim, to zsh cause it to simply lock up. I have been googling this for ~6 hours now, but 'screen locks/hangs/freezes' (with obvious additional search terms) brings up too many irrelevant results, and from what I can tell no relevant ones.

There are not many compilation options for gnu screen, what info can I provide to help anyone willing to help me?

  • You can try cat /etc/redhat-release (from memory), or lsb_release -a. Screen should be available from the official repositories, so you could have tried yum install screen. – Wodin Dec 21 '10 at 23:31
0

Strangely this seems to have been a TERM issue. I was ssh'ing from a terminal outside X running zsh. When I would ssh in the system changed term to vt220, under these settings, or manually setting TERM="linux" on the remote host screen would lock. From X however I ssh from an rxvt-unicode terminal running zsh, manually set TERM on the remote host to 'rxvt', then launch screen. Screen sets the term to "screen.rxvt" and it works fine.

I really think I will only be ssh'ing from X from now on anyway, I did it form the terminal because X was still compiling on the box I was using (gentoo). So I guess this can be solved as a TERM issue, though I am not sure of a workaround outside of X if anyone else encounters this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy