I had set this up a while ago on a different computer, but I can't get it running now. I've followed the directions at http://pigtail.net/LRP/printsrv/cygwin-sshd.html and I'm getting the following error.

Gulshan@GSJK-PC ~
$ cygrunsrv -S sshd
cygrunsrv: Error starting a service: StartService:  Win32 error 1069:
The service did not start due to a logon failure.

I don't know where to start troubleshooting this error... I've ran Cygwin with admin privileges every time I installed it and when I run the cygrunsrv or net start commands.

net start sshd doesn't work either.

  • What version of windows are you running now and what version of windows where you running when it worked? – Nifle Oct 2 '11 at 9:54
  • @Nifle Windows 7 now, and I believe XP worked. – gsingh2011 Oct 3 '11 at 2:47
  • I have no real insight but have you tried starting the cygwin shell as administrator? – Nifle Oct 3 '11 at 10:55
  • @Yes, that was included in the question. – gsingh2011 Oct 4 '11 at 2:50
  • No, you said that you ran as administrator when you installed it. – Nifle Oct 4 '11 at 7:57

Try the ssh-host-config command in a Cygwin shell. That sets up the privsep user, and the host keys, etc. I just set Cygwin ssh up on Windows 2008 R2, and once I did this, it worked for me.

  • Yea, I did that. It gave me a couple warnings, but they seem to be common warnings. No luck. – gsingh2011 Oct 6 '11 at 1:28
  • Did you start the server by typing net start sshd? If that fails, check the server log in /var/log/sshd.log. I've found helpful error messages in there. – Fran May 16 '12 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.