I have a 2nd Gen (FW800) Drobo connected to my computer, which boots both Lion, and Windows 7. The Drobo has HFS+ volumes as I use OSX predominantly.

I've installed Windows 7, the Unibrain FW driver, and the Bootcamp HFS driver. Windows recognizes other HFS volumes on local disks, and recognises the Drobo LUNS in the Device center, but it won't let me get to the actual volumes to browse them.

HSExplorer does let me mount the device, so I know it exists, and can be accessed. Windows just doesn't seem to see the volumes as drives.

What do I need to do to get them recognised?

3 Answers 3


There are other products for accessing HFS+ under Windows, although most are commercial :

jhfsplus (free, based on MacDrive)
Paragon HFS+ for Windows ($19.95, 10-day trial)
MacDrive ($49.99, 5-day trial)

You could at least use the trial of Paragon to see if it improves the detection of HFS+ volumes, as Paragon makes good products.

  • Tried jhfsplus, and paragon - neither work.
    – Alex
    Oct 9, 2011 at 15:31
  • Then the only suggestion I can think of, is to update your Drobo to the latest firmware and software versions, and if the problem persists reformat the disk using this latest version.
    – harrymc
    Oct 9, 2011 at 17:03
  • Make sure you check your disk for errors under OS X before you mount the disks under Windows. Some Windows drivers can only read cleanly unmounted HFS volumes.
    – billc.cn
    Oct 9, 2011 at 22:53

It's definitely a file system problem. Could you move any data that needs to be accessible to Windows and the Mac to a volume that both understand, like a FAT-32 volume?

  • These are multi-terrabyte volumes, with some pretty large files on them. I'm not really ready to dump all that on FAT32, and don't have the spare drives to do copy the data to while I reformat.
    – Alex
    Oct 9, 2011 at 15:32
  • To be clear, I'm looking to get the drives up and visible in Windows, or a definitive answer that it can't be done. Reformatting isn't an option
    – Alex
    Oct 9, 2011 at 15:32
  • Ah, OK then. I don't know, but it looks like some kind of HFS+ driver for Wimdows is what you need, and I don't know why the ones you have aren't working.
    – mauvedeity
    Oct 10, 2011 at 22:28

I have a 2nd gen Drobo Firewire 800 as well, formatted at 16TB HFS+ (although I use 4x 2TB drives), I'm using Lion and Windows 7 on an early 2008 iMac 20". On Windows 7, the only driver that I loaded was the one that comes with bootcamp and it mounts Drobo as a readonly drive, as it does with all the other external HFS+ volumes. Did you check if you have the latest firmware on Drobo? (I'm not really expecting this to matter but in a rare case maybe it would.) The version of Drobo Dashboard though, shouldn't really matter at all. Maybe the Unibrain FW driver conflicts with the bootcamp driver. Try connecting Drobo with the USB cable to see if it shows up. I know it's slower, but if it works on USB you'll know that it's definitely a Firewire driver problem.

  • I tried the Bootcamp driver first, and switched to the standard FW driver, as well, same result. Great to hear that it works for you though. As long as I know I can do it, I'll press on. Yes, I have the latest firmware, etc.
    – Alex
    Oct 10, 2011 at 2:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.