I just installed a large backlog of Windows Updates (I have Windows 7 Ultimate 64-bit) and now a handful of programs are acting strangely (not opening, crashing, etc)

I went to try to diagnose the program using the Event Viewer, but when I open it up I get the error "Microsoft Management Console has Stopped Working" immediately after I double-click on the icon.

Is there any way for me to figure out what is going wrong? I have another Windows 7 PC, that I tried to remotely view the logs from, but I got the error "The RPC Server is Unavailable". I'd like to start up the service, but oh wait, I can't open anything in the "Administrative Tools".

I'd like not to re-install Windows, as I had just done so a couple months ago after a Windows Update jacked up my graphics card drivers.

  • Sounds like some services have been disabled? or are not running correct. If you had said XP and gave those symptoms I would say the eventviewer service. I wont be disabling it again :-) Windows event log service? event collector, and task scheduler, all tied together somehow, what a mess.
    – Psycogeek
    Oct 2, 2011 at 20:07
  • I've been through this issue (cannot open the even viewer after an update). I think removing .NET via Add/Remove programs (Windows features in there) and then rebooting and adding it again solved the issue for me, but I'm not sure. So I'm entering this as a comment and not an answer.
    – haimg
    Oct 3, 2011 at 0:32
  • I tried repairing .NET with no luck. Event Viewer also doesn't work in Safe Mode.
    – Erik W
    Oct 3, 2011 at 3:50
  • I think this Link answers.microsoft.com/en-us/windows/forum/windows_7-performance/… Would be valuable on a Question like this. There is some specific bug, but it is not the exact same symptoms.
    – Psycogeek
    Jan 19, 2012 at 14:25

3 Answers 3


I had this problem on Windows 10.

One of these two tools worked:

  1. mbam-cleaner
  2. FarBar cleaner. With which I cleaned up the following items in my 'fixlist', one of them was the problem, I suspect it was one of the services at the end.
HKLM\...\Run: [Energy Management] => C:\Program Files (x86)\Lenovo\Energy Management\Energy Management.exe [17097200 2013-12-21] (Lenovo (Beijing) Limited)
HKLM\...\Run: [EnergyUtility] => C:\Program Files (x86)\Lenovo\Energy Management\Utility.exe [193008 2013-12-21] (Lenovo(beijing) Limited)
HKLM-x32\...\Run: [331BigDog] => C:\Program Files (x86)\USB Camera\VM331STI.EXE [552960 2013-03-01] (Vimicro)
HKLM-x32\...\Run: [RemoteControl10] => C:\Program Files (x86)\Lenovo\PowerDVD10\PDVD10Serv.exe [95192 2013-03-09] (CyberLink Corp.)
HKLM-x32\...\Run: [APSDaemon] => C:\Program Files (x86)\Common Files\Apple\Apple Application Support\APSDaemon.exe [59720 2013-09-13] (Apple Inc.)
HKLM-x32\...\Run: [iTunesHelper] => C:\Program Files (x86)\iTunes\iTunesHelper.exe [152392 2013-11-02] (Apple Inc.)
HKLM-x32\...\Run: [BlueStacks Agent] => C:\Program Files (x86)\BlueStacks\HD-Agent.exe [811792 2014-01-20] (BlueStack Systems, Inc.)
HKU\S-1-5-21-108747036-1597516160-757816120-1002\...\MountPoints2: {e0c45c6a-63b0-11e5-bf10-342387e7b755} - "F:\AutoRun.exe" 
HKU\S-1-5-21-108747036-1597516160-757816120-1002\...\MountPoints2: {e0c45cd4-63b0-11e5-bf10-342387e7b755} - "F:\AutoRun.exe" 
HKU\S-1-5-21-108747036-1597516160-757816120-1002\...\MountPoints2: {e0c4686a-63b0-11e5-bf10-201a06921033} - "F:\AutoRun.exe" 
HKU\S-1-5-21-108747036-1597516160-757816120-1002\...\MountPoints2: {e0c468bd-63b0-11e5-bf10-201a06921033} - "F:\AutoRun.exe" 
HKU\S-1-5-21-108747036-1597516160-757816120-1002\...\MountPoints2: {e0c469b3-63b0-11e5-bf10-201a06921033} - "F:\AutoRun.exe" 
HKU\S-1-5-18\...\Winlogon: [Shell] C:\windows\Explorer.exe [4528168 2015-07-10] (Microsoft Corporation)  Catalog9 - Broken internet access due to missing entry.  Catalog9-x64 - Broken internet access due to missing entry.  DefaultScope value is missing
StartMenuInternet: (HKLM) Opera - C:\Program Files (x86)\Opera\Opera.exe hxxp://www.istartsurf.com/?type=sc&ts=1430075528&from=obw&uid=ST500LT012-9WS142_W0VHXHCYXXXXW0VHXHCY
R2 AdaptiveSleepService; C:\Program Files\ATI Technologies\ATI.ACE\A4\AdaptiveSleepService.exe [103424 2013-04-25] () [File not signed]
S3 AMD FUEL Service; C:\Program Files\ATI Technologies\ATI.ACE\Fuel\Fuel.Service.exe [361984 2013-04-25] (Advanced Micro Devices, Inc.) [File not signed]
S2 BstHdAndroidSvc; C:\Program Files (x86)\BlueStacks\HD-Service.exe [402192 2014-01-20] (BlueStack Systems, Inc.)
R2 BstHdLogRotatorSvc; C:\Program Files (x86)\BlueStacks\HD-LogRotatorService.exe [385808 2014-01-20] (BlueStack Systems, Inc.)
S3 LSCWinService; C:\Program Files\Lenovo\Lenovo Solution Center\App\LSCWinService.exe [272776 2014-10-16] ()
R2 NitroDriverReadSpool8; C:\Program Files\Common Files\Nitro\Pro\8.0\NitroPDFDriverService8x64.exe [230408 2012-12-14] (Nitro PDF Software)
R2 X5XSEx_Pr148; C:\Program Files (x86)\FreeRide Games\X5XSEx_Pr148.Sys [56136 2012-08-03] (Exent Technologies Ltd.)
  • when you say 'farbar cleaner', it suggests there is something that is called that, and that that is the proper name for it. When I google I see a thing called FarBar, called and abbreviated also as FRST FarBar Recovery Scan Tool. Not referred to as 'farbar cleaner'. You could say some antimalware program known as FarBar. Also even its description on bleepingcomputer doesn't describe it as cleaning. "to diagnose malware issues. It is also possible to run FRST in the Windows Recovery Environment in order to diagnose and fix boot issues." But FarBar is an author not a program..
    – barlop
    Jan 4, 2017 at 0:55
  • you can see a list of FarBar's software here bleepingcomputer.com/download/publisher/farbar I can't comment much regarding the one you used-on the subject of to what extent it diagnoses or to what extent it removes or resolves.. But diagnosing or providing info for diagnosing, isn't cleaning, and fixing boot issues isn't typically described as cleaning. Hopefully you will fix that. I will leave these two comments here because others reading should learn about the importance of referring to products by their proper names.
    – barlop
    Jan 4, 2017 at 1:02

Some ideas which may help..

  1. Download and run "Anvir Task Manager Free". You can even put a portable version on a USB stick. This will show you all the processes and services running on your machine. You can start and stop services or change their startup type. And you can view and switch on/off all the things that startup from the registry.

  2. If you're really curious to look at the eventlog, you could find other tools for dumping events to a file (sorry I've never used these).

  • These comments are not really helpful to solve the underlying problem.
    – haimg
    Oct 3, 2011 at 0:31
  • 1
    These suggestions were to address problems raised by the OP of (1) not being able to start and stop services (2) not being able to display the event log. Both possibly helpful tasks in diagnosing the underlying problem. It was entered as an answer not a comment because in the past I've encountered stupid restrictions on this website on who is allowed to post comments.
    – Viren
    Oct 5, 2011 at 1:03

I would start with seeing if I could roll my computer back using a restore point and then adding back the updates a few at a time until I found the offending update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .