For the life of me, I can't seem to chown my /var/www folder on my server. i want to:

chown -R ftpuser /var/www

And it returns Invalid Argument on every file change attempt. I've tried sudo with the same result. I'm logged in as user ubuntu while trying to do this, and ubuntu currently owns the /var/www folder.

I'm doing all this to try to get vsftpd working, and so far I can log in via ftp and list the folders, but I cannot write files, and I believe it's because of the permission issue above.

Any ideas how I can get this working?

migrated from stackoverflow.com Oct 4 '11 at 3:20

This question came from our site for professional and enthusiast programmers.

  • So if ftpuser owns the www folder, how is Apache supposed to be able to do anything in there? Don't change ownership... just add ftpuser to a common group with Apache and chgrp the dirs/files. – Marc B Oct 3 '11 at 18:02
  • ok, so i tried adding ftpuser to ubuntu (the current owner/group). i still get '553 Could not create file' in Filezilla when trying to upload a file? – bmilesp Oct 3 '11 at 18:08
  • What are the perms on /var/www? – Marc B Oct 3 '11 at 18:09
  • the permissions are set to 775 on var/www and recursive dirs – bmilesp Oct 3 '11 at 18:12

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy