1

I have my personal email hosted on OVH (personal hosting plan) and I'm not able to send mails using msmtp.

Here's a typical session

ignoring system configuration file /etc/msmtprc: File o directory non esistente
loaded user configuration file /home/klez/.msmtprc
using account default from /home/klez/.msmtprc
host                  = ssl0.ovh.net
port                  = 465
timeout               = off
protocol              = smtp
domain                = localhost
auth                  = choose
user                  = federicoculloca%xxxxxxx
password              = *
ntlmdomain            = (not set)
tls                   = on
tls_starttls          = off
tls_trust_file        = (not set)
tls_crl_file          = (not set)
tls_fingerprint       = (not set)
tls_key_file          = (not set)
tls_cert_file         = (not set)
tls_certcheck         = off
tls_force_sslv3       = off
tls_min_dh_prime_bits = (not set)
tls_priorities        = (not set)
auto_from             = off
maildomain            = (not set)
from                  = federicoculloca@xxxxxxxx
dsn_notify            = (not set)
dsn_return            = (not set)
keepbcc               = off
logfile               = (not set)
syslog                = (not set)
reading recipients from the command line
TLS certificate information:
    Owner:
        Common Name: ssl0.ovh.net
        Organizational unit: Domain Control Validated
    Issuer:
        Common Name: OVH Secure Certification Authority
        Organization: OVH SAS
        Organizational unit: Low Assurance
        Country: FR
    Validity:
        Activation time: lun 31 gen 2011 01:00:00 CET
        Expiration time: mer 15 feb 2012 00:59:59 CET
    Fingerprints:
        SHA1: F9:DC:41:F9:A2:38:51:9B:56:E4:98:E6:CD:81:31:42:E6:0E:26:6D
        MD5:  FC:EC:F3:8F:28:E4:7E:28:99:89:E6:BB:C9:DF:71:CE
<-- 220 ns0.ovh.net ssl0.ovh.net. You connect to mail427.ha.ovh.net ESMTP

--> EHLO localhost

<-- 250-ssl0.ovh.net. You connect to mail427.ha.ovh.net

<-- 250-AUTH LOGIN PLAIN

<-- 250-AUTH=LOGIN PLAIN

<-- 250-PIPELINING

<-- 250-8BITMIME

<-- 250 SIZE 109000000

--> AUTH PLAIN xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

<-- 235 ok, go ahead (#2.0.0)

--> MAIL FROM:<federicoculloca@xxxxx>

--> RCPT TO:<example@example.com>

--> DATA

<-- 250 ok

<-- 250 ok

<-- 354 go ahead

--> hello world

--> .

<-- 554 mail server permanently rejected message (#5.3.0)

And my configuration

# ~/.msmtp
# Mostly from Peter Garrett's examples
#  https://lists.ubuntu.com/archives/ubuntu-users/2007-September/122698.html
# Accounts from Scott Robbins' `A Quick Guide to Mutt'
#  http://home.nyc.rr.com/computertaijutsu/mutt.html

account xxxxx
host ssl0.ovh.net
from federicoculloca@xxxxxx
auth on
user federicoculloca%xxxxxx
password xxxxxx
tls on
tls_certcheck off
tls_starttls off

Any idea?

  • Maybe your message body is empty. The error occurs (also) with a empty message body. – user140278 Jun 15 '12 at 6:11
0

Are you sure user federicoculloca%xxxxxx is the right setting? I mean the percent sign, not the rest - perhaps @ is better than %.

Bu usually 554 mail server permanently rejected message means that the receiving side doesn't accept your mail because of spam suspicion. Do you have you tried other mails and other recipients?

  • The % is right as per settings they mailed me when I subscribed. And I also tried @, but still didn't work. I also tried other recipients, to no avail. – Federico klez Culloca Oct 4 '11 at 9:26
  • sorry, I'm out of options now. Perhaps you should consult your provider's helpdesk. Or try sending mail with thunderbird or another mail program. If thunderbird works, the problem is related to the msmtp configuration, otherwise the problem is not at your side. – guenter Oct 4 '11 at 15:43
  • the problem is almost surely the configuration, since Thunderbird and Evolution both work. I'll try and consult my provider. Thanks – Federico klez Culloca Oct 4 '11 at 16:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.