42

How can spell checking be turned off for a portion of a OneNote page?

The set language form does not have a checkbox (like the one for Word 2010 has). There are over 100 languages to choose from, but all of then will perform some sort of proofing.

6

I'm afraid this is not possible. In order for this to happen, a OneNote page would have to be come much more complicated, there is no way to 'fine-tune' spell-checking that specifically.

However, you can tinker with the spell checking options in Tools -> Spelling -> Spelling Options:

enter image description here

Try experimenting with some of the highlighted options above. For example, you can have it suggest words from the main dictionary only, or use a custom dictionary, or even edit the word list yourself...

You can also disable spell checking or only have it check it in one sweep. To have it check in one sweep, uncheck Check spelling as you type.

  • Not the answer I was hoping for, but good to know. – Jay Elston Oct 4 '11 at 22:07
  • 1
    The other answers here suggest that it would not be so much more complicated for this useful feature to be implemented. – sdenham Jun 28 '16 at 12:40
  • 1
    I would have hoped MS would have put a null language in the list. Word had this (called "(no proofing)") before the "Do not check spelling and grammar" checkbox replaced it. – Stewart Apr 26 '17 at 12:23
63

A variation on the language support trick from Petri above seems to do what you want:

  1. Select a block of text in your document that you want to disable for spell checking
  2. Go to the Review tab and select Language > Set Proofing Language
  3. Select a language for which you and your likely readers have no dictionary, e.g. Afrikaans, Cherokee etc. work for me.

The other text will still default to being in the original language, e.g. English (UK) in my case and will still be spell checked as normal.

You can also keep the proofing language pane open to make it quicker to apply the same change to multiple areas of your document.

I guess the reason for this functionality is for when you quote something in another language, you can spell check it correctly.

  • Works on the Mac version of OneNote too except the menu is Tools->Set Proofing Language… – Philip Kearns May 28 '17 at 13:45
  • 4
    Thanks - don't know why MS could not just include "none" as an option. – Ian Horwill Aug 15 '17 at 8:26
8

Install OneTastic addin, which has one of macros, named "No spell check"

http://omeratay.com/onetastic/

http://www.omeratay.com/onetastic/?r=downloadMacro&id=1DF08B3C629840759A86237CC090F8A9

Works perfectly

P.S. Onetastic is an add-in, which is made by Microsoft OneNote team developer, and has lots of useful features. You can trust it.

6

The trick works for me is to set page language to something you don't have language support in your computer. For example I changed page language to "Afrikaans". Then OneNote does not make spelling checking for this page because Afrikaans -dictionary is missing.

  • 3
    It worked for me. Highlight the area you don't want spell-checked then set proofing language to Afrikaans. Only the selected section of the page uses the new language. – xcud Mar 30 '15 at 14:52
  • Thank you! While it is somewhat obvious, this "hack" has never occurred to me! – MFH Mar 20 '17 at 22:44
  • This is workable. I wonder if there is any way to add a language named "disableProofing"? – Jay Elston Nov 15 '18 at 21:00
4

I discovered by accident that if you precede the paragraph where you don't want red spell checking marks to show up with the symbol for, "therefore" then that paragraph will not show words that contain spelling errors underlined.

You can make the symbol for, "therefore" (3dots) by holding down the Alt key then typing 8756 then releasing the Alt key. This works on Windows anyway. I don't know if it works on other operating systems.

If you don't want the symbol to show up you can just select the symbol and make it white or the same color as the background if you are using a colored background. You could also reduce it's font size to 1.

Note: this will only get rid of the red spell check marks; it will not turn spell check as you type off. So words that are normally corrected as you type such as: recieve will still be corrected to: receive as you type.

  • This I have GOT to try. – music2myear Mar 20 '17 at 16:57
  • Holy canoly! That actually works. Remove this symbol and all the misspells are marked. Add the symbol back and words already marked will remain marked, but any further misspelled words will not be marked. That is quite an interested workaround Jerry. – music2myear Mar 20 '17 at 17:09
  • That's crazy! Shame you can't define custom bullets or arbitrary tag symbols. Not sure I'll use this rather than marking the text with a missing proofing language, but I've set up auto-correct to turn :. into ∴ just in case. – Ian Horwill Aug 15 '17 at 8:37
  • Nice -- it works for a paragraph. But what happens if you have several lines (such as a directory listing or a section of code). Each line is its own paragraph. I don't see hoe this helps that case. – Jay Elston Nov 15 '18 at 20:59
1

As of version 2016 there is an option in File -> Options -> Proofing then check Hide spelling and grammar errors. Even though one leaves on the other checkboxes, one is not directly informed of a spelling error unless one hovers over the word, even if it is typed in.

enter image description here

Hit Save when you are done.

  • Thank you for posting this. I have a question -- this is a global option, is there any way to enable this for only a portion of a one-note page? – Jay Elston Nov 15 '18 at 19:24
  • Sadly no. I am able to use it because my use is generally for notes on technical items and processes, so spelling is not important. When needed, turn the option to the default position to show the red lines. – ΩmegaMan Nov 15 '18 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.