Since about four days ago, every time I restart or reboot my Windows 7 machine, the system comes back up with Microsoft Security Essentials disabled. The network and sharing icon in the status bar appears with the teal-colored ring over it.

Entering the Network and Sharing Center from the icon takes extra time, but when it appears, there is nothing in the active networks list. This is ironic, because testing the network by pulling up websites in Chrome works just fine.

Next, I tried to start CPU-Z, which requires UAC elevation. I started it from an icon on the desktop, which caused the pointer to get a teal ring on it. At that point, Windows Explorer and all the desktop icons stopped responding.

I tried another elevated app from the Start button app list. Same result, only that time the Start button UI stopped responding.

So, I tried Task Manager, through the ctrl-alt-del mechanism, which worked, but clicking on "Show processes from all users" resulted in the same behavior: Task Manager UI stopped responding altogether, including not permitting the UI to move around on the screen though I was able to start other TM instances. Curiously, the "frozen" TM still updated its list of running processes.

10 minutes after trying all this, all the UAC prompts I expected appeared, the status bar changed to report that MSE and the network were working fine, and everything seemed to return to normal.

What could be going on?

  • Sounds like malware. – Ramhound Oct 5 '11 at 17:33
  • No malware, according to MS system scans. – Rob Perkins Oct 6 '11 at 21:02
  • Follow the instructions here but replace shutdown by boot and by adding -postBootDelay 600 (to let it wait 10 minutes, don't do anything yourself until the trace has been made), feel free to share the file so we can take a look as the whole boot is kind of complicated to look into if this is your first time. If there is any software like problem then this should allow one to pinpoint it. Good luck... – Tamara Wijsman Oct 19 '11 at 0:31
  • Note that you can xperf the startup process, or do something like this or this. – ta.speot.is Apr 20 '13 at 10:42

This can always be some installed product that takes 10 minutes to initialize itself after boot. Security products would be my first guess.

You can test this by booting in Safe Mode. If this fixes the slow-down, then try to turn off one by one (or several at a time) all products that startup with the computer until you find the guilty one. Autoruns for Windows is best for this, as it can undo actions and also can take a backup of the existing startup applications. But better create first a system restore point as an additional protection.

If this does not help, then something is very wrong with your computer and needs repairing. Malware can never be ruled out, but a damaged system is more likely, as Windows Update can also break your system.

I would start repairs by How to Repair Windows 7 System Files with System File Checker. This requires a Windows 7 installation DVD of the same service-pack level as your installation.

If SFC has found nothing, the next step would be Repair Install. This will only refresh Windows without affecting the installed applications.

If you get your system working again, do Windows Update manually, rather than letting it do so automatically, just in case.

But take backups and ensure you have all the materials necessary to reinstall everything, or that your computer has a recovery partition, since the repair itself might make your computer unbootable.

  • Selections from Autoruns appear to make the problem take a shorter time, or go away altogether. I still haven't correlated anything consistently. – Rob Perkins Oct 22 '11 at 6:13
  • 2
    This kind of research is always painfully slow, especially if it is not simply caused by one product but by conflict between several. – harrymc Oct 22 '11 at 7:34
  • Well, my largest concern is that I don't have keyloggers or malware present, but I can't think of any way to install those without elevating, and I haven't been surprised by an elevation prompt at any point. – Rob Perkins Oct 23 '11 at 20:21
  • Bounty awarded here. This appears to be giving me a good path forward. – Rob Perkins Oct 24 '11 at 4:46
  • Monday Morning bootup after an idle weekend lacked the delay's I've described. This methodology didn't answer the question, but the cause is buried in the items I disabled with Autoruns. Therefore, this is the selected answer. – Rob Perkins Oct 25 '11 at 0:09

Scan the disk using a disk utility such as Spinrite to ensure that the disk is readable.

Then try Soluto (to find slow startup suspects).

  • +1 for suggesting a disk check. Sounds like bad HDD activity to me as well. A standard chkdsk in read-only mode (no /F or /R) is a good (free) starting check as well. – Ƭᴇcʜιᴇ007 Oct 18 '11 at 3:54

If you suspect malware see this post.

If there is no malware, then enable boot logging and then restart the system, then have a look at the logs when the system becomes responsive

  • No malware, according to the scans. Boot logging produced over 1.7 million events, but upon boot, the system was immediately responsive. – Rob Perkins Oct 6 '11 at 21:05
  • @Rob: No malware detected is not the same as no malware. – harrymc Oct 18 '11 at 5:38
  • @RobPerkins: Of course, but these do show you what's going on. Feel free to share the PML file with us, it gets small when you zip it... – Tamara Wijsman Oct 19 '11 at 0:27
  • OK I'll do some more backchecking and logging in the morning. – Rob Perkins Oct 19 '11 at 6:02

@harrymc's answer was very useful, but a few days later I noticed that Windows Defender and Microsoft Security Essentials appeared to be in a race condition: The WD service was starting and stopping every few seconds. This might be the cause of all the delays, but I can't tell.

  • Is this the final answer to your question? Otherwise you might want to consider adding a comment on harrymc's answer instead. – slhck Nov 2 '11 at 15:44
  • Ha! good point. I don't know if things are deterministic enough around here to say... – Rob Perkins Nov 2 '11 at 15:49
  • 1
    Just pointing out before somebody comes along and flags this as "not an answer" :) Any way, you might want to ping him by adding a comment if you need more details. – slhck Nov 2 '11 at 15:51
  • Thanks for the courtesy, @slhck. I did ping him, and it looks like that's the thing. I'll leave all of this here for the record, though, and leave his answer marked as "correct", since it's the quickest way to begin troubleshooting, in my opinion. – Rob Perkins Nov 9 '11 at 19:51

Turn off secure desktop and see if that helps.

  • 1
    It'd be great if you could expand your answer to more than just a link, explaining how to turn off secure desktop, and how that'd solve the problem. Thanks! – slhck Apr 20 '13 at 10:33
  • it's about the UAC elevation prompt, in my experience, when multiple UAC prompt comes out together, then it will content for the secure desktop and hang. Thus disable secure desktop MAY BE a solution. – user218473 Apr 21 '13 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.