1

I upgraded my openssl version with the command:

rpm -i --nodeps openssl-0.9.8p-1.x86_64.rpm

And now I get following error for almost every command I enter:

/lib64/libc.so.6: version `GLIBC_2.7' not found (required by /lib64/libcrypto.so.0.9.8) 

Will a simple update of GLIBC be enough? Like

rpm -i --nodeps glibc-2.9-2.9.x86_64.rpm

I'm kind of scared to try that because of the damage i've already caused.

migrated from stackoverflow.com Oct 6 '11 at 7:14

This question came from our site for professional and enthusiast programmers.

  • Please help me...i'm on a customer system and am freaking out. thanks in advance – almightyBob Oct 5 '11 at 12:48
0

Yeah, well, requiring --nodeps should be a big flashing sign that you're about to shoot yourself in the foot. Replacing core packages with some random rpm from the internet is unlikely to be successful, as you've noticed. Better luck next time, dude.

FWIW, you might be able to install the original openssl rpm by booting from a CD and playing with chroot.

Or, since Suse 10.3 isn't supported anymore anyway, you might as well update the entire system while you're at it.

  • yeah thats what i turned out doing. thanks for the heads-up. – almightyBob Oct 5 '11 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.