I am trying to upgrade to windows 7 64-bit and it is giving me this error. Problem is they are all on the same partition, C:... I even checked all the registry keys and they all point to someplace on the C:\ drive. Why am I getting this error?

Is there any way to force windows to upgrade, because i am trying to upgrade from win7x64 to win7x64, so I’m not sure if that would be causing this error, but I would supposed that it would tell me that i cannot upgrade from the version of windows currently installed or something like that, not this error.

The reason I am trying to "upgrade" is in a desperate attempt to get rid of a virus, i wound up deleting a few things I shouldn't have (biggest issue is the user32.dll). Windows still boots ok, but if I try and launch almost any exe, then I get the error "The program can't start because USER32.dll is missing from your computer. Try reinstalling the program to fix this problem" I tried launching the installer, but I get the exact same error. I checked the system 32 folder and there IS a user32.dll, so I'm not sure why it would say it is missing, and I also tried copying it from another computer with win7x64 in our house, but still nothing different.

Is there any way to fix all of this without having to do a clean install?


You seem to be upgrading to the same version that you have, hoping to repair the damage.

Try a System Restore first:

  • From safe mode at boot or as-is from the current user.
  • System Restore back to a point before problems started, if possible.

Try 'Last Good Configuration' at boot. With the User32.dll still there, can you check that the path is correct against the other computer in the house? If this does not work you can try a Windows product 'update'.

How to correct common User32.dll file errors

This is from a Vista help site, but should work the same (I could not find the Windows 7 64bit user32.dll help). The links are not much good but it does give detail on how to update when using the command prompt.

This website has a long list of possible problems with "user32.dll and links on 'how to fix' ", showing the error:

This application failed to start because user32.dll was not found. Re-installing the application may fix this problem.

After update or restore, check all anti-virus are updated and possibly all related drivers.

  • 1
    Check both C:\Windows\System32 and C:\Windows\SysWOW64 folders. One id for x64 and other is for x86 applications. – Ganesh R. Oct 10 '11 at 8:05
  • Somehow system restore got disabled, the file is in the same location as the other computer, and I was unable to do the update, as my version of windows would not validate (yet another glitch). I'll try the safe mode and last known good configuration, but because this is not an error with windows starting, but rather an error with the applications starting I doubt it will do anything. I will give it a shot nonetheless. TBH, I've pretty much given up at this point, my computer had been glitching for a while now and I have just accepted that I am going to have to start clean. Thanks anyways! – Sean Oct 11 '11 at 6:07

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.