This question already has an answer here:

I am trying to uncheck the the Read-only attribute from a folder (and all subfolders). That folder is my own data folder, that I copied as is to a TrueCrypt drive on my laptop.

The TrueCrypt drive is NOT mounted read-only!

I have been able to write to that drive without any problem. In fact, I have been able to copy that entire data folder to the drive without any problem.

When I right-click that folder's Properties, uncheck that greyed-out checkmark next to Read-only, click OK, I am prompted with a Confirm Attribute Changes dialog box. I confirm OK to Apply changes to this folder, subfolders and files and everything seems to be proceeding OK.

But when I right-click that folder's Properties again, I am surprised to see that the greyed-out Read-only attribute is still checked!

enter image description here


What could I do to workaround this?

UPDATE: Thanks to the tip below (regarding "red herring") I checked the security tab and was indeed surprised that only the Administrator had write access to that folder.

Moreover, even CREATOR OWNER didn't have read/write permissions to the folder and even when I check Allow Full Control for CREATOR OWNER, everything remains unchecked for CREATOR OWNER. What gives?

Nevertheless, I tried to get away with giving Modify permission to the Administrative account under which I am currently logged in. It seems to have been accepted (checkboxes are checked), but when I try to write to a file inside that folder, I still receive Access Denied.

Any idea how to continue from here, in order to workaround this problem?

enter image description here

UPDATE 2: I just tried the above on a NON-TrueCrypt folder (i.e. regular data folder on C: drive). The same problem persists. So I started suspecting the tool version that I am using (Eclipse 3.5.2 attempting to modify .classpath file which was originally created by Eclipse 3.6.1)... So, I tried editing that file by hand (using Noteapad) and, lo and behold, no access problems for Notepad.

My conclusion: The problem is neither in Windows XP, nor in the folder itself. It's in the tool (Eclipse) that tries to access it.

marked as duplicate by Ƭᴇcʜιᴇ007, Dave, Dave M, Scott, Brad Patton Apr 4 '13 at 19:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 1 down vote accepted

This checkbox is a red herring. It doesn't really do anything on folders. If you look, it's probably a square in the checkbox, instead of a check mark.

If you are still having problems writing to the folder, look for a security tab in the same dialog box where you see the checkmark and change the settings there instead.

  • Thanks +1 for this tip. Please see my update above as, thanks to your reply, I have been able to make some progress, but haven't solved the access problem yet. – uTubeFan Oct 10 '11 at 17:19

Your problem isn't the folder's read-only status. See this answer for lots of good info on what that means and why it's the case.

With your update, it's much more likely the case that you need to take ownership of the folder & its contents first before you can modify the permissions. To do that, go into the Advanced Security Settings for that folder (click the Advanced button in your 2nd screenshot), switch to the Owner tab, select your account, make sure that the Replace owner on subcontainers and objects checkbox is marked, then click Ok.

After that's done, you may need to back out of the folder properties window and re-open it before you can correctly modify the permissions afterwards.

Moreover, even CREATOR OWNER didn't have read/write permissions to the folder and even when I check Allow Full Control for CREATOR OWNER, everything remains unchecked for CREATOR OWNER. What gives?

CREATOR OWNER is a special ACE, and doesn't really apply to folders themselves, only their contents. See here for more information.

  • Thanks +1 for your answer. I did as you suggested and, interestingly, the ownership of that folder was already assigned to the Administrative account under which I am logged in. I followed your suggested steps anyway, taking ownership, backing out, etc. But CREATOR OWNER still has all checkboxes unchecked and the Access Denied problem persists. Any idea how to workaround this? – uTubeFan Oct 10 '11 at 17:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.