I get the following error message on a Windows 7 64-bit computer whenever I try to install anything using Windows Installer (.msi):

This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.

I tried reinstalling and updating Windows Installer but with no luck. What is wrong? It just suddenly happened.

Ihave tried everything recommended on this page, and the pages it links to: http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/the-installation-package-could-not-be-opened/6f49baee-ec1f-479f-a889-031162baad1e

  • Are there any telltale entries in the system logs immediately prior to your experiencing this issue? – music2myear Oct 12 '11 at 22:01
  • @music2myear: Not at all. – Dynamic Oct 13 '11 at 10:00
  • What is your user level, at least local administrators? – N4TKD Oct 14 '11 at 14:05
  • One more question, do you get these errors installing the same packages on a different computer? – music2myear Oct 14 '11 at 14:12
  • @JohnDR: I'm local admin. – Dynamic Oct 14 '11 at 14:18

Do these before reinstalling SP1:

A few more questions: How many MSI files have you tried that have returned this message? Are they from a particular vendor? Are any of them Microsoft files downloaded from their website? And are they supposed to be compatible with the 64-bit OS or Windows 7?

First, where are these packages being run from? Were they downloaded to your Desktop, are they on a disk, or are they in a system directory such as somewhere inside C:\Windows?

If they are inside a system directory, try copying them to your desktop or another folder you have full control of and running them from there.

Second, try running sfc /scannow from your command prompt to check for and repair any system files or registry issues.

Third, are they blocked? Right click on the .msi file and select properties. There will be a button near the bottom of the dialog Unblock. Click this and try running the files again.

Fourth, make sure that the folder you've got the files in have the appropriate permissions. Check the security settings for the folder these files are in and make sure that the user SYSTEM has full access. After all, the msiexec will run as SYSTEM and will need full control of the directory and all files inside it.

Trying re-installing Windows 7 sp1 to perform a "lite" operating system repair.

  1. Download the package from the MS website, you'll probably need the one labeled windows6.1-KB976932-X64.exe.

  2. If you already have the Service Pack installed, you'll want to uninstall it. Sometimes these packs don't have a "repair" or "reinstall" function. Instructions from the MS site for uninstalling.

  3. After the uninstall is complete and you've rebooted, begin the installation of the package downloaded in step 1.

| improve this answer | |
  • I've tried installing ActivePerl and MySQL. Different vendors. Both compatible with Windows 7 64 bit. I've tried installing these files from the Disk Drive and the Downloads folder. The files were not blocked. I have all permissions. Give me time to get the rest of the info. – Dynamic Oct 14 '11 at 18:49
  • Was the SYSTEM account set to Full Control for the folder and all subfolders and items? – music2myear Oct 14 '11 at 19:25
  • Yes it was and is ;-). – Dynamic Oct 14 '11 at 19:56
  • Installing SP1 was no help... any other ideas. – Dynamic Oct 15 '11 at 15:02
  • Unfortunately not at this point. Plugging the error you gave into google came up with several results though, in addition to the ones I gave here. You may want to give that a try. – music2myear Oct 15 '11 at 15:11

Download the file using a different browser.

I guess Google Chrome was corrupted but Internet Explorer worked just fine.

| improve this answer | |
  • Although the answer sounds stupid, this was my case too. It happened with Google Chrome on a Windows 8 machine. – True Soft Jun 26 '15 at 13:01
  • It was my case too, download by chrome was corrupted – vietnguyen09 Apr 8 '16 at 8:17

Make sure your anti-virus/firewall software is not blocking the install. My situation was running Trendnet Micro. Once it was disabled, installation was successful.

| improve this answer | |

Please down-load the file again and run, it will solve your issue. I got the same message when I was trying to install Node.js (which I downloaded from the office-site). What I did was, I deleted that file which gave me this error and download it again. It worked for me.

I guess that it happened because the first setup file was corrupted for some reason.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.