I'm encountering a strange phenomena in Ubuntu 11.04.

My Thinkpad x220, has two operating systems installed, Ubuntu 11.04 and Windows 7.

In Windows, everything is OK. My network speed is very fast, no matter if wired or wireless.
But in Ubuntu, it takes a long time to open a website, both wired and wireless (but wired is faster than wireless).
In wireless, I tried to ping google.com. It would take several seconds to respond and the delay was more than 1000ms. If I ping google.com in wired state, it's also very slow. It also took several seconds to respond but the ping program said the delay was only 10ms.

My wireless card is a Realtek 8192c.

Does this relevant to Ubuntu drivers?

My traceroute to google.com:

martin@martin-ThinkPad-X220:~$ traceroute google.com
traceroute to google.com (, 30 hops max, 60 byte packets
1 ( 2.995 ms 51.938 ms 52.460 ms
2 ( 52.168 ms 52.174 ms 52.216 ms
3 ( 52.119 ms 52.170 ms 52.175 ms
4 ( 52.749 ms 52.750 ms 52.739 ms
5 ( 52.682 ms 52.673 ms *
6 ( 52.647 ms 23.242 ms *
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 martin-ThinkPad-X220.local ( 1763.444 ms !H * *
  • You're probably going to need to give a lot more information to get help on this, like what wireless card you have. And 10 ms is not slow. That's 6x faster than my connection to Google. Commented Oct 12, 2011 at 4:25
  • Can you provide a traceroute google.com wired and wireless
    – Paul
    Commented Oct 12, 2011 at 4:59
  • I edit my post, and add traceroute info
    – jiluo
    Commented Oct 12, 2011 at 5:31

1 Answer 1


I am just about to solve this problem too. It seems like this problem is in more distributions, as I have the same problem on Ubuntu 9.10.

There can be more reason for this: problem in the kernel, in the driver for internet connection device, but more likely it is problem in ipv6 or DNS.

Here is the way how to disable the ipv6: http://www.joehacker.com/index.php?title=Ubuntu_Tips#Disable_IPv6_on_Karmic_9.10 (This wasn't worked for me)

Then I tried to change DNS servers, to open DNS as it is written here: http://www.unixmen.com/linux-tutorials/567-internet-connexion-is-very-slow-on-karmic-koala-solution- (This worked for me, but I don't like this solution, since the DNS server assigning by my DHCP is working from another OS)

I've also found out, that the problem is due to Ubuntu is sending DNS queries in IPv6 first, so there is long time to switch queries into IPv4 and getting response from not ipv6 supporting DNS. So using the DNS which support IPv6 or to set not to use IPv6 on your PC can help this issue.

Anyway, I am going to try and solve this issue yet, so I will have some new experience.

I know you use another distribution of Ubuntu, but it could be exactly the same problem.

  • I will try it!And due to your post, I found many useful information, thank you very much
    – jiluo
    Commented Oct 12, 2011 at 11:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .