I'm using windows 7 on a laptop. On the laptop keyboard, for some reason, the quote key (which has both double and single quote on it) is doing some "clever" annoying things:

  1. When I press single-quote (or double-quote), windows doesn't send any characters until I press it twice (resulting in '' or "")
  2. When I press it before a vowel, I get some kind of accented character. As I usually only write English, this is annoying.

The backtick/tilde key is subject to similar behaviour.

This is not a duplicate of the linked question because the two problems have completely different solutions. This question was caused by an internationalisation setting being activated; that other question was caused by keys being set to dead.

I have not attempted to set up my computer to process anything other than English. My keyboard appears to be (in so far as these things are standard on laptops) a standard US qwerty keyboard.

How can I stop this happening?

up vote 174 down vote accepted

I would first make sure that your "input method" settings is set to "US" (and definitely not "United States-International"). You can do this through the Control Panel. A restart may be required.

For Windows 7:

  1. Open Control Panel
  2. Click on Clock, Language, and Region, and then Region and Language.
  3. Click the Keyboards and Languages tab, and then click Change keyboards.
  4. Under Installed services, click Add.
  5. Double-click the language you want to add, double-click Keyboard, select the text services options you want to add, and then click OK.

See also:

For Windows 10:

  1. Open Control Panel.
  2. Click on Clock, Language, and Region and then click on Language.
  3. If you don't see a card reading "English (United States)" in the list, click on "Add a language" on the toolbar to add it.
  4. On the same row belonging to the "English (United States)" card, make sure there is a line reading "Keyboard layout: US". If it does not (that's the assumption of this answer), click on the "Options" hyperlink belonging to the same line, to the left.
  5. In the "Input method" section, click on the "Add an input method" hyperlink to add a keyboard layout called "US". Delete any other installed input methods pertaining English.

See also:

  • 6
    Thank you! I didn't realise that these settings required a restart to take effect. – Marcin Oct 13 '11 at 12:40
  • 6
    Yeah, one thing I've learned is that it never hurts to log off and back on when you are playing around with the control panel settings, computer management, or windows registry (however annoying it can be :) ). – Dminish Oct 13 '11 at 12:42
  • 3
    I stop and start explorer via the run window "cmd /c taskkill /f /im explorer.exe & explorer". Most of the times it will allow changes to many things to take effect. That works on XP should work on 7 and 8 – Michael Mantion Jan 5 '15 at 7:54
  • 2
    BEWARE! You will lose pound sign £ (AltGr+Shift+4) by switching from United States-International to US layout, but it will solve aforementioned annoyance. – igor Jul 31 '17 at 10:12
  • This doesn't work if you want to keep the International keyboard (for AltGR functionality). The only choice is to use Microsoft Keyboard Layout Creator to create a custom US International Keyboard without Dead Keys. – Agustín Lado Nov 8 '17 at 21:52

In the case of Windows 8/10 (not the question, I know) - these accent keys are active when the keyboard is US International (US INTL), and will be deactivated if you change to US ENG.

You can switch between the two using the short-cut "WindowsKey + Space".

Also, if you look at the desktop taskbar (bottom of screen) - to the left of the Date/Time display, you should see a tile displaying the current keyboard (in this case US ENG or US INTL) - click on it to bring up a selector.

  • 2
    Worked for me, I was working with Sublime Text editor and it was driving me crazy while programming. Thanks! – Șerban Ghiță Nov 3 '14 at 19:21
  • 1
    This is really a PITA when you're used to work with Mac OS ... Apple Key-Space means "Spotlight search" there, so I press it frequently in Windows .. – TheEye Nov 9 '15 at 11:33
  • Left alt + left shift was bound to change keyboard languages for me in Windows 7. (Shortcut should be listed in the window where you add more keyboard languages). Changed to non-international map and it's back to normal, thanks. – aportr Jan 8 '16 at 12:13
  • In my case US Eng was active and I still had the issue. I fixed it by selecting International from the language bar and then immediately selecting US Eng again. – misterManSam Aug 17 '16 at 1:49
  • 1
    +1 The short-cut WindowsKey + Space is working in Windows 10 too. Thanks :) – Krishna Mohan Nov 2 '16 at 15:00

You probably inadvertently pressed ctrl shift '.

This is a windows shortcut that affects some applications (examples include: mIRC, gtalk, wordpad, etc) and causes the behavior you are describing. Pressing the shortcut again or restarting the computer will disable it (and hence Dmnisih's answer is incorrect).

  • Does your list include cmd and xemacs running under cygwin? If not, then your diagnosis is incorrect. – Marcin Oct 13 '11 at 17:29
  • SharePoint Designer 2010 is also affected by this shortcut. – MrChrister Feb 24 '15 at 17:00
  • This did the trick for me. "Thanks" – ViVi Dec 15 '16 at 6:59
  • @Marcin Anything that uses a win32 rich text input would be affected by this. CMD does, and IIRC GTK running under cygwin does. The diagnoses is correct. – Tritium21 Apr 1 at 2:30

If you press space after the quote then it will be as if you have only the one quote

  • Does this work with any key? Or just space? – Marcin Nov 28 '13 at 16:07
  • any key as far as I can see... – rupweb Mar 27 '14 at 16:30
  • 4
    yeah but pressing 2 keys to make a single key appear isn't the answer to the problem. – simo.37920 Jan 19 '17 at 6:33

Here’s how I fixed it:

  1. Open the Regional and Language Options control panel.
  2. Click on the Keyboards and Languages tab.
  3. Click on the Change Keyboards button.
  4. Remove all the installed keyboards until none are left except English US.
  5. Restart your computer.
  • 3
    Usually "International" variants of keyboards cause have this behaviour. Note that you cannot remove keyboard which is currently selected and the restart is not probably needed. (but Windows often surprise me with requested reboots) – pabouk Jan 24 '14 at 13:27

It typically happens when one accidentally hits the left Ctrl and right Shift keyboard keys.

The way to recovery is in hitting these Ctrl-Shift keys two more times.

It has been illustrated nicely at http://www.pctips.smittystips.com/v_laptop_keyboard_errors.php

  • Wow, thanks! A simple fix for me when my keyboard was already selected as US English. I almost skipped your suggestion thinking it couldn't possibly be right! :) – pcdev Mar 5 at 12:10
  1. If you press " once, followed by Space bar, it gives ' without a space next to it.
  2. If you press ", while holding Shift, and then press Space bar, you get " without a space next to it.
  3. If you press " followed by a consonant, then you get the same result as (2). For example:

    ", followed by m, gives 'm.

    Shift+", followed by m, gives "m.

  • What solution/action are you suggesting? – meatspace Jan 28 '15 at 15:42
  • What I am suggesting is, the space-bar will do the trick. There is no need to change the Region and Language setting, 'because' this problem occurs, in general case, on any keyboard layout. – jaydeepsb Jan 29 '15 at 11:43
  • 1
    Your answer is really difficult to read and could be improved if you edit it and use <kbd>space</kbd> and <kbd>"</kbd> so that it formats the names of keyboard keys to make them easier to read. – Ryan Feb 27 at 15:52
  • Thanks for describing the misery of the original poster in so many words. Still, this is not an answer to the question of "How can I stop it?" Downvoted. – user477799 May 16 at 5:21

For WinXP

Open RUN window (winbutton + r) type the following line and press enter

cmd /c intl.cpl ,1 & taskkill /f /im explorer.exe & explorer

Click "detail"

Highlight and remove all keyboards except US

Click OK twice and you should be done

protected by bwDraco Dec 23 '15 at 19:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.