I recently replaced my internal macbook (model: 2007 black) HDD with a OCZ Agility 3, and the laptop has been blazing, just brought back to life :). However, I noticed that the startup is not as quick as I expect from an SSD it actually takes longer than my previous HDD. I think it also has to do with OSX Lion, but I can't be sure. I followed this guide to also activate TRIM in Lion. Whenever I put my computer to sleep and bring it out it freezes and the only way to use my computer would be to hold the power button to shut it down and restart, but thats not good for the drive or components. What is wrong here?

I actually just removed the TRIM support that I added in the guide above and it still had the same problem. Its not always freezing but every now and then when I bring my computer out of sleep it freezes.

Already tried posting on the OCZ forums but haven't had any help, wondering if someone here has any advice?

  • I am having this same issue, do you also get sluggish response when you save or edit and then save files? thx – Drewdin Feb 27 '12 at 20:56
  • Check the firmware version of your SSD and see my updated answer below please – GiH Feb 27 '12 at 21:25
  • I have version 2.15 and i shut off hard disks to sleep. I have my fingers crossed that it will be good, thx! – Drewdin Feb 28 '12 at 16:52
  • looks like OCZ is going to RMA my drive, not a good start! – Drewdin Feb 29 '12 at 19:48
  • it will be well worth it! – GiH Feb 29 '12 at 20:19

UPDATE: Feb 27, 2012

I contacted OCZ about this issue and it turned out my firmware was out of date. Upon upgrading to firmware version 2.15 everything has been perfect! I recommend contacting OCZ about the issue, if you are still having it, as I'm not able to access the firmware update information page anymore for some reason.

So it turns out that removing the option in the system preferences of putting the hard disk to sleep worked. System Preferences > Energy Saver > and I unchecked "Put the hard disk(s) to sleep when possible". This workaround is no longer needed, please update your firmware per the above note.

  • except that this is not a solution. they have a bug that when you put your drive to sleep and return the drive cannot be found. for laptops this is just, a non-starter. the firmware udpate procedure requires taking the drive to a windows system, depending on where you are. – cyphunk Jul 23 '12 at 16:18

Some SSDs with Sandforce 2 controllers, like your OCZ Agility 3, require a firmware update to prevent problems with waking from sleep in MacBooks.

Make sure you have the most recent firmware in your SSD, and make sure that OCZ is keeping up with the firmware releases from Sandforce.

  • i haven't performed a firmware update because in the second link above (in my question, the OCZ forums one) the guy said he updated his firmware to no avail, i guess i should try it though – GiH Oct 13 '11 at 21:39
  • How did you update your firmware? – cyphunk Jul 23 '12 at 16:19
  • contact them and they will give you a step by step – GiH Jul 27 '12 at 3:52
  1. Boot from a Lion recovery volume on an external drive (Flash or whatever), run Disk Utility and pick "Repair Disk" for your SSD boot volume. If there are no errors,
  2. Pull the SSD, put the original spinny disk back in, see if it works properly.

First step is to figure out if it's the disk that's corrupted or faulty; if the disk repair shows no errors and things still don't work properly with a normal spinning drive you've probably got a fault in your logic board (aka motherboard).

  • thanks, ill give that a go. I ran disk repair from disk utility normally, not from a recovery volume and it seemed fine. However putting the original HDD back in won't help because the laptop would freeze all the time with the hard disk, not only when coming out of sleep. – GiH Oct 13 '11 at 19:26
  • There were no errors on the disk – GiH Oct 15 '11 at 17:54

I fixed mine (late 2008 MBP + OCZ Agility 3) by resetting the PRAM and NVRAM - tip given by the OCZ customer support team.


I realize this an old question but to anyone wondering why it takes so long to boot with an SSD, make sure it is set as the startup disk. To do this go to System Preferences > Startup Disk.

If it isn't set OS X will wait and search for drives at startup until it finds one, this is what takes the extra time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.