I have a recent (AMD Athlon II X4 645 based) PC. Although the motherboard has integrated sound, I use an ancient-but-still-pretty-good Creative Soundblaster Audigy Platinum Ex. I dual boot Windows 7 and Windows XP at the moment.

Today, about an hour ago, using Windows 7, I noticed that I wasn't getting any sound when I started a game of Oolite. I know the sound was working around an hour before that. Not sure if I rebooted in-between or not, but I had the speakers switched off for a lot of that time, so didn't notice exactly when the noises stopped.

At that point, I had only used Windows 7 all day (I haven't allowed XP on the internet for a few years now). There were no driver updates in this time, nor any settings changes. The most recent drivers for this card were released in 2010 IIRC. About all I've done today is browse a few web sites, watch a couple of videos in VLC, and update some backups on an external hard drive.

I checked the speakers and cable, and the state of the sound card and drive in the device manager, and of course the volume control. Everything seemed fine. I thought maybe the old card had failed.

But when I rebooted from Windows 7 to XP as a final check, all the sound was fine. I rebooted back to Windows 7 again and the sound was dead again.

The fix was simple enough in the end. The driver executable for the sound card (SBAX_PCDRV_LB_2_18_0017.exe) offers to remove existing drivers if they're found, so I ran it once to remove the drivers, rebooted, then ran it again to reinstall them and rebooted again. All sound is now fine.

But this isn't very satisfying. Obviously reinstalling (the exact same version of) the driver has reset some setting that had got broken, but ideally I'd like to know what the cause was so that I can prevent it happening again.

Any ideas?


The most recent drivers for this soundcard have turned out to be a bit buggy. I only got this particular glitch a couple of times, but I found a much bigger problem when I tried to use a microphone in Windows 7 64-bit. Basically, chunks were missing from the audio waveform, giving the impression of one of three or four buffers being wiped to all zeros every time it's used, which is several times per second recording 48KHz.

My final solution was to give up on that soundcard. I'm currently mostly using motherboard HD audio, though I also have a USB SoundBlaster Audigy 2 NX which is slightly less obsolete and doesn't have the same driver issues (but also doesn't have MIDI or firewire ports).

closed as too localized by Ƭᴇcʜιᴇ007, Nifle, Simon Sheehan, Steve314, studiohack Nov 13 '11 at 5:38

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • @slhck - thanks for the spelling fix, but are you sure about the title change? My guess is that someone will probably read no more than half the question, then post a suggestion that I uninstall then reinstall the drivers to fix the problem - which of course I've already done. That's why I thought I'd make it as clear as possible in the title that the problem is fixed, just not explained. – Steve314 Oct 13 '11 at 22:05
  • Ah, I see. Well, let's just keep it there! I thought it was a bit "weird" to read in a title. No big thing! :) – slhck Oct 13 '11 at 22:09
  • @Steve314 you might consider revising the title. the current title makes it sound like it doesn't need to be answered anymore – Nate Koppenhaver Oct 13 '11 at 23:35
  • @Nate - any better? – Steve314 Oct 14 '11 at 0:10
  • @Steve314 yep :) – Nate Koppenhaver Oct 14 '11 at 17:10

Is the on-board sound still enabled (there is usually an option for this in the motherboard's BIOS). If so then Windows7 could have just decided that it should be the default sound device instead of the add-on card. I don't run Windows 7 anywhere, but I have certainly seen that behaviour somewhat randomly with Windows XP.

The sound was probably working, but playing through the on-board device which probably didn't have any speakers plugged into it so you'd not notice.

Reinstalling the device drives would solve this, if it was indeed your issue, because installing such drivers tends to include setting the "new" device as the system default as the last step of the install. You can check and change the default audio device yourself in one of the control panel areas (I couldn't tell you where under Windows 7, but it should be something not too dissimilar to XP where it is found under "sounds and audio devices" in Control Panel and can also be accessed from the right-click menu on the volume control in the task tray).

  • +1 for a good try, but no. I checked for that just in case. There was a second audio device, but not the motherboard one - it was for the HDMI port on my graphics card. This wasn't the default, but I disabled the driver anyway - I use DVI for my monitor, and though it has a HDMI input, it has no speakers. I haven't owned a TV for a few years now. For the motherboard audio, the BIOS has this set to "auto" and the device manager can't see it at all. – Steve314 Oct 14 '11 at 12:44
  • Anyway, in the volume control, it says which device it's using, and you get that level meter that shows the sound that should be output. I could see the sound that should have been output yesterday, but I couldn't hear it. – Steve314 Oct 14 '11 at 12:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.