I have a HP Compaq Presario C700 laptop with Windows 7 installed on it.

My laptop's keyboard is not working properly; some keys never work and some keys will keep on pressing. I've formatted the OS but it didn't solve my problem.

I bought an external USB keyboard and it works well. As some keys in the built-in keyboard activate themselves, I still couldn't work effectively.

After searching Google I tried the following steps to disable the built-in keyboard:

  1. Disabled keyboard drivers:
    This didn't work because when the system reboots, the driver gets installed again automatically.

  2. Installed irrelevant driver for keyboard:
    This failed - I couldn't install the driver. After rebooting it installed the correct driver automatically.

Can anyone help explain how I can temporarily uninstall my built-in keyboard? I don't want to remove it manually (removing the hardware cable).


Look at this article, it will help you to disable your laptop keyboard by uninstalling your keyboard driver.

  • Go to Start–>Search type in gpedit.msc
  • Click the file to open the Local Group Policy Editor and show Windows who is in control!! You want to go here: Computer Configuration->Administrative Templates->System->Device Installation. Click on the subfolder Device Installation Restrictions on the left and on the right side you will see the possible restrictions.
  • Right Click on Prevent Installation of Devices not described by other policy settings and edit this option, set it on ENABLED.
  • Reboot Windows and enjoy its inability to pollute your system with its standard driver, open gpedit.msc again and revert the change so you will be able to install your driver.
  • 3
    Note GPEDIT is only available in Pro and up versions of Windows. – Moab Aug 17 '15 at 22:11
  • On Windows home edition no group policies. The alternative workaround that worked for me is updating device driver and choosing some wrong driver. – Adil Aliyev Apr 21 '16 at 16:09
  • 1
    Using the method in this answer prevents plug-and-play from working properly for other devices. It is better to find out your device Hardware ID in the Device Manager. Copy this ID and then instead if "Prevent installation of devices not described by other policy settings", you should enable "Prevent installation of devices that match any of these device IDs". Click on the "Show" button. Paste the device ID in the empty field. Check "Also apply to matching devices that are already installed." and reboot for the changes to take effect. – n.abing Aug 19 '18 at 1:05
  • It will block other drivers installation, so its not feasible solution. e.g if you connect phone it wont detect it. – MrNams Mar 15 '20 at 5:37

For laptop Asus X82S using Windows XP, I was successful using these steps

Please go to C:\Windows\System32\Drivers\.... You will see some files start with kb, change kbfiltr to kbfiltr_del. And you will have done it.

This will disable laptop keyboard. At the moment, I use USB keyboard. And no problems for keys anymore.


I'm not familiar enough with this machine to tell you how easy it is, but generally the keyboard on a machine like this is end-user replaceable, so you could simply replace it. Alternatively, you could just open the machine and unplug the data cable connecting it to the motherboard. (I suggest this way specifically so that it doesn't cause you grief in the BIOS or something like that, if the occasion arises.)

  • i don't need to remove my machine . Any other way?? – sam Oct 15 '11 at 4:15
  • @sam - I have no idea what you're trying to ask. "Remove my machine"? – Shinrai Oct 16 '11 at 5:17
  • i don't need to remove my laptop manually and remove the keyboard's harware cable. Another another way other than this? – sam Oct 19 '11 at 15:50
  • 1
    It's the best way to do it - if you're afraid to open it, I don't know what to tell you. – Shinrai Oct 19 '11 at 16:17
  • Also, it sounds like you don't speak English natively, so I'm not sure I understand you correctly, but it sounds like you're trying to say that you would prefer not to do this. If I read you word for word it sounds like you mean you're physically incapable of it for some reason - if that's the case please say so. – Shinrai Oct 19 '11 at 16:31

Installing the wrong driver for the laptop keyboard, as outlined here worked for me: https://superuser.com/a/788372/7018


In case you can't access gpedit.msc (group policy), what you can do is, uninstall the standard keyboard driver from device manager and don't restart the computer. Just sign out and log back in. You'll see your inbuilt keyboard won't be working. Tested on my Windows 10 Home Edition 1607, and it works fine. Now, I can safely put my external keyboard on the laptop's keyboard and not worry about the keys anymore. Hope it helps!

  • Thanks Shanks :) You saved my life. – Suraj Jain Aug 20 '20 at 14:33

There is a way to disable a specific builtin keyboard with registry:

  1. In Device manager, select Properties for the keyboard in question.
  2. Go to Details.
  3. Select "Device Instance path" from the list.
  4. Note the string, it will be used later.
  5. Download SysInternals psexec
  6. Run psexec /s /i regedit - this is because even Administrators can't modify these registry settings
  7. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum
  8. Further navigate according to string from step 4.
  9. Change the value of ConfigFlags to 1.
  10. Reboot.
  11. When you want to enable keyboard again, change the value of ConfigFlags to 0.

Installing a proper driver through device manager worked fine for me.

I have an acer. All I did was click the option which let me choose from a list of drivers. I installed a toshiba japanese driver and shutdown the laptop. When started back up, the keyboard did not work at all. (P.S.: I did not restart; I shut it down.)


My try on Windows10.
1. Open Device Manager, right click Standard PS/2 Keyboard, select Properties, select tab Driver, click Driver Details and you can see a list of three Driver files.
On my laptop, there're:
In my exploration, i8042prt.sys is my laptop keyboard's driver together with touchpad, kbdclass.sys is general keyboard driver and SynTP.sys is touchpad driver. Disabling laptop keyboard is also disabling laptop touchpad.
2. In my case, I need to rename C:\Windows\System32\Drivers\i8042prt.sys, find the driver file, right click driver file, select Properties, select tab Security, click Advanced, click Change, type YOUR_USERNAME, click OK, click OK, click OK, right click driver file, select Properties, select tab Security, click Advanced, click Add, click Select a principal, type YOUR_USERNAME, click OK, checked Full control, click OK, click OK, click Yes, click OK.
Now you can rename the driver file, I renamed it to i8042prt.sys_bak.
3. Reboot.


I solved my similar problem by clicking Start>Devices and Printers, then clicking on the icon for the computer and clicking the Hardware tab in the Properties dialog. Then I double-clicked the keyboard entry to open the Driver Properties dialog and clicked the Change Settings button, which should require administrator privileges. Once that dialog opens, click the Driver tab, and the option to disable the driver should be available. Click disable and bingo, laptop keyboard all gone away. Make sure you have you USB keyboard installed properly first.

Worked first time for me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.