11

I have a minimal installation of CentOS 5.7 32-bit on a VM.

The apropos command always returns "nothing appropriate"

[root@localhost ~]# apropos man
man: nothing appropriate

Even after I run updatedb. It works on another CentOS server I have.

4 Answers 4

8

Try executing 'makewhatis' as root. That updates the man page database, and creates it if it doesn't already exist, which it may not on a fresh installation.

'updatedb' updates the database for 'locate', and probably isn't related to this issue.

2
  • 7
    If using CentOS7 the command 'mandb' has replaced makewhatis.
    – Kentgrav
    Jul 22, 2015 at 0:35
  • 1
    I have run mandb as root. and it works. Feb 18, 2018 at 7:34
8

sudo mandb solved the problem for me. It regenerates the apropos database, but you have to make sure you run it with sudo.

2
  • 2
    what and how, what did it do? Aug 27, 2019 at 3:24
  • Apparently it regenerates the apropos database. Answer modified.
    – RufusVS
    Aug 29, 2019 at 15:48
0

sudo mandb -c solved this issue for me on CentOS 8. The database needed to be created after a fresh install.

2
  • This answer has already been given twice. Apr 4, 2020 at 20:55
  • "sudo mandb -c" is the correct one, thanks. Already given onces are slightly different :)
    – izy
    May 6, 2020 at 0:08
0

sudo mandb worked for me on Ubuntu 22.04, no idea why this wasn't an issue on any of my other systems.

Slight annoyance is if you just run mandb without root privileges as some other answers forgot to mention, you just get unhelpful failure:

0 man subdirectories contained newer manual pages.
0 manual pages were added.
0 stray cats were added.
0 old database entries were purged.
1
  • Question is about CentOS
    – Toto
    Mar 12 at 7:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .