39

I have a smb share set up (the link smb://a.b.c.d/sharename) that I am attempting to connect to from Windows.

I'd like to either connect directly using a browser or mount the share to a virtual drive.

The problem is I can't seem to get it to work properly. Can anyone let me know how this works?

I'm running Windows 7 64-bit

1
  • 1
    Linux and Unix, including Mac OS X, use forward slashes in address paths, as you show in your example. However, Windows uses back slashes.
    – user422696
    Feb 25, 2015 at 23:31

4 Answers 4

10

You should be seeing the share in the Network neighborhood and be able to use it from there. Just open Windows Explorer and click on Network.

If you cannot see it, then you have a connectivity problem with the sharing computer.

5
  • The problem is that it's inside a corporate network with thousands of nodes, so the sharing is limited in the network folder to only those that are local to my office. I can still reach the ip address, but I can't connect to it using smb
    – ewok
    Oct 17, 2011 at 16:55
  • 23
    So this is on another network segment. Try in the Windows Explorer address bar to use the following syntax: \\a.b.c.d\sharename.
    – harrymc
    Oct 17, 2011 at 17:21
  • That seemed to work. Not sure what I was doing wrong before. Thanks
    – ewok
    Oct 17, 2011 at 17:25
  • 1
    Just straight \\MACNAME did the trick for me (with File Sharing for that user's account configured under Mac Sys Prefs: Sharing: Options) Jun 22, 2015 at 1:32
  • 1
    For anyone using Windows 10 post-2020, please keep scrolling to White_King's answer Jan 3, 2021 at 0:52
13
  1. Open Windows Explorer.
  2. In the path bar, write \\a.b.c.d (pay attention to the backward slashes).
  3. That should create a new entry in "Network" and show its content.
  4. Double-click on the share you want, for instance sharename in the example of the question.
1
  • 1
    This worked when I wanted to connect to my Mac via SMB. Thanks.
    – xji
    Oct 14, 2021 at 16:01
8

After the creator's Update in Windows 10, on new Installs Windows disable SMB1 by default in an attempt to stop a virus.

That might be a problem if you want to browse your shares because it will stop you from detecting them, 2 Options:

  1. if you want to enable it Open Windows Features either by searching on windows start or: Control Panel -> Programs & Features -> Turn Windows Features on or off.

Tick SMB1.0/... And restart

  1. Or you can just map a drive to the share: Win+E [This PC] -> Computer Menu -> Map network drive. Choose a Drive letter and specify the Share Network Path and Finish.
1
0

In my case I was trying to access Mac files from Windows 10. Actually there is a setting in Mac, which shows at what name is this computer visible.

in my case it was akshay.local

from Windows, I can just access my mac by putting \\akshay.local in the Run Program URL (Win+R > \\machostname.local)

Be sure that you have already enabled file sharing on your Mac

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.