I have a laptop Dell D820 with Intel Core Duo T2500 @ 2.00 GHz, more than four years old, still in good condition.

When I benchmarked the CPU using the PerformanceTest 7.0 from http://www.cpubenchmark.net and compared the results (of the CPU only) to same Dell laptops, I found out that my score is about 1/3 compared to others.

My score is ~ 350 and other Dell laptops with same CPU have about 950 - 990.

I ran the test at least three times with no other (significant) programmes/services in the background.

Does anyone have an idea why my CPU is slower than other comparable CPUs? Thanks for any hint.

UPDATE: The laptop is plugged to power and not running any background services like antivirus.

UPDATE: I ran a memtest to check if RAM could cause it and it's probably not causing it. Two comparable laptops were about 2-3 times better and third laptop was about 1/2 worse than mine (in RAM test). All of them, including the worse, are still about 2-3 better in CPU benchmark.


  • Intel T2500 @ 2.00 GHz
  • Measured speed: 1995.0 MHz
  • Number of CPU: 1
  • Cores per CPU: 2
  • Multiplier: 6x
  • Bus speed: 167 MHz
  • Front side bus speed: 667 MHz

Can it be caused by 167 MHz bus speed? FSB and RAM is @ 667 MHz

UPDATE: I ran diagnostics in BIOS (except the looong RAM test) and everything passed OK. The only settings in BIOS related to CPU were:

  • Current clock speed: 1.000 GHz
  • Minimum clock speed: 1.000 GHz
  • Maximum clock speed: 2.000 GHz
  • Processor cache size: 2048 KB
  • None of theese fields are changeable

  • SpeedStep Enable (set to Enable)

  • Off = Place the system into the lowest performance state and prevent the Intel SpeedStep applet or native operating system driver from adjusting the processor's performance.
  • Enable = Allow the Intel SpeedStep-enabled CPU to operate in multiple performance states.
  • The factory default setting is Enabled.

Tools like Speccy or RightMark CPU Clock Utility are telling me that both cores are @ 997.5 MHz (core clock), @ ~ 695 MHz throttled; multiplier 6x, temperature ~ 38 celsius. It's not overheated but it seems to me throttled and I don't know by what. Any idea?

  • Did you check your power saving settings before you run the test? Also you have to turn off all anti-virus and similar softare that could slow the system down. – billc.cn Oct 18 '11 at 16:59
  • Laptop is plugged to power, power scheme is set to Home/Office desk (in WinXP). I'm not running any antivirus or other services in the background. (question updated) – dwich Oct 18 '11 at 17:03
  • Did Dell ship any power management software with your computer? Normally the frequency of a laptop CPU is always throttled down unless you change it in the power management software. – billc.cn Oct 18 '11 at 17:05
  • run a memtest.. sometimes faulty ram can affect benchmark scores. – WalterJ89 Oct 18 '11 at 17:06
  • 2
    Clean out the dust bunnies in the CPU fan. It's probably being thermally throttled down. – Anthony Giorgio Oct 18 '11 at 18:41

Thanks everybody who tried to help me. Finally the problem was solved.

Other people reported that Current clock speed in BIOS is the same as Maximum clock speed. Which was different on my laptop - I had Current clock speed same as Minimum clock speed. There was something wrong with it not in OS, not in BIOS but "deeper".

  • Current clock speed: 1.000 GHz
  • Minimum clock speed: 1.000 GHz
  • Maximum clock speed: 2.000 GHz

I also updated BIOS and nothing changed. When I set BIOS to default values and restarted, message was displayed saying

A 65W AC power adapter has been determined. Your system will operate slower and the battery may take more time to charge.

The adapter was already a suspect after about 7 hours of investigation, what might be the problem. This was the final evidence. What can cause CPU to operate slower? CPU speed can be set in BIOS, in OS, so something really deep in the system is the cause.

I use 65W car/air adapter all the time, it's small and great. I asked my friend to give me my old big 90W adapter back and.. The CPU works now at 2 GHz and is not throttled down.

  • It's likely that you were able to overcome the limitation anyway by using RMClock or ThrottleStop on Windows and processor.ignore_ppc=1 on Linux. Dell is known to be an unfair player, at least when it comes to AC adapters. See Workaround for Dell “Power supply not recognised” issue for details. – user Apr 26 '17 at 22:19

Try to check if it doesn't overheat and thus throttle down. I check CPU temperature with little program called CoreTemp and I used RMClock to check if CPU is not throttling down.

Edit: I had similar problem with my dell inspiron 1720. It started with overheating. I got it cleaned and it seems that overheating gone away but then after reaching about 50 Celsius it was freezing. CPU was 100% all the time. Restarting didn't help, but if I shut it down for some more time CPU's got cooler and everything worked well (for some time). Then I installed RMClock and I discovered that when CPU was 100% it was clocked about 800MHz instead of 2.4GHz (WTF?). I played with BIOS settings and it occurred that when I switched off Intel's SpeedStep I could 'overclock' my CPU to 2.4 with RMClock. But it was causing to overheat the CPU to 90 Celsius. So I got it cleaned again and described what was happening and how to cause it. And that second time they cleaned it well and I don't have these problems for a year now.

TL;DR I recommend to have it cleaned and when you will be picking up your computer run these benchmarks to check if it doesn't happen again.

  • Hi Beniamin, I've updated the question. According to RMClock it's throttled down from ~995 MHz to ~695 MHz. I've no idea why the core clock is 1.0 GHz and not 2.0 GHz and what's throttling it down. – dwich Oct 18 '11 at 18:23
  • In my case it was overheating and thing called Intel SpeedStep. I got my dell cleaned well and it gone away. – Beniamin Oct 18 '11 at 18:36
  • I don't think it's overheated. Temperature is bellow normal (38 C) and there's no dust or dirt in the fan. What I see as a problem is that everything from BIOS to various tools is reporting cores as 1.0 GHz throttled down to ~ 690 MHz because of multiplier 6x not 12x. If multiplier is raised to 12x, cores are reported as 2.0 GHz but still throttled to ~ 1400 MHz. – dwich Oct 18 '11 at 22:51
  • Did you open it? Even if it looks ok from outside it doesn't have to be like that inside. Have you ever changed thermal paste? And in my case also it didn't look like overheating because once temperature raised to 50 Celsius, CPU throttled down and didn't raise above 40. But when I turned off SpeedStep in BIOS and "overclocked" it with RMClock it started to boil. Do you have SpeedStep in BIOS? – Beniamin Oct 19 '11 at 8:54

Have you updated the BIOS yet from Dell? Or any drivers. Make sure you have the latest and greatest. A driver issue could be causing interrupts and hurting performance.

I would also boot into a portable linux environment and run some CPU benchmarks. It might just be a windows/driver/software issue, not a hardware issue.

  • I have the latest BIOS. Also tried to boot to linux and got the same results - cores are displayed as 1.00 GHz not 2.00 GHz and benchmark is worse than in WinXP. So it's not a Win/driver/software issue. – dwich Oct 18 '11 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.