I'm running Windows 7 64-bit on a new Samsung laptop and accessing the internet okay via ethernet cable to my university's ISP. Some sites work fine (e.g. google.com) but I can't access others at all (microsoft.com, topshop.com).

I can't connect to those sites in safe mode with networking. And ping and tracert both fail. There's no proxy.

Other users can connect successfully to these sites using my cable and socket.

I've tried all the following with no success:

  • using various browsers (IE9, FF, Chrome)
  • creating a new user
  • updating drivers
  • clearing the DNS cache
  • using OpenDNS and Google's DNS
  • turning off Avast
  • tweaking the MTU
  • running MS malicious software removal tool
  • running Spybot S&D
  • reviewing the hosts file
  • disabling the IPv6 options
  • repairing / resetting winsock settings
  • disabling advanced javascript options

I have run out of ideas... can anyone see anything I've missed??!

  • 2
    Where does tracert fail exactly? – slhck Oct 19 '11 at 11:34
  • Does the ping resolve to an IP address? Ping www.google.com should resolve to for example. Can you ping the IP address instead of the name? – Yeodave Oct 19 '11 at 11:36
  • 2
    nslookup the domains that work and those that don't – m0skit0 Oct 19 '11 at 11:54
  • @Yeodave: www.google.com is not a good example... it is big enough to resolve to different IPs depending on where you are (and/or other things?). In France I currently get, in Germany (similar to yours) for ping www.google.com. dig www.google.com actually lists six A records with different IPs in the same subnet... – Jonas Heidelberg Oct 19 '11 at 12:06
  • @JonasHeidelberg good point, I assumed as he's in UK like me (mentions UK retailer Topshop) he'd get same IP as me but that's not guaranteed it seems. – Yeodave Oct 19 '11 at 12:25

I had a similar issue and it was because of MTU size but I see you have already tried that idea. Also I was on DSL and was using PPPoE.

Try setting your Laptop MTU to be much lower say 1000 and see if it works. Then adjust your MTU to be higher.

| improve this answer | |
  • Genuine question as I'm not familure with MTU: would MTU size affect pings and tracerts to different hosts? – Yeodave Oct 19 '11 at 16:31
  • Sorry, Did not see the message until today. Were you able to solve this problem. MTU is basically the (max) size of the data that can be sent in 1 ethernet packet. Because of some encapsulation/tunneling protocol the MTU has to be smaller. This is a directive to the IP stack to break up the packets to smaller size. In most cases tracerte and pings are 64 bytes only so should not effect but u cannot be sure. – TheVyom Nov 1 '11 at 3:31

If pinging www.google.com on the affected computer resolves the same as it does on a working computer then the issue is not related to DNS lookup. If you have tried two DNS providers like OpenDNS and Google I doubt this is the issue.

If is doesn't resolve to an IP address or resolves to a local ip address like then you have a DNS problem or are infected. Not being able to resolve www.microsoft.com is a classic virus tactic to stop you getting updates or support.

If you can't ping the resolving IP address either that address does not respond to pings for security reasons (www.google.com does though) or something is blocking you. Turn of Windows Firewall and any other port blocking firewall software.

Finally, check you only have one network connection active and your computer is using the right one. Turn off Wireless and Bluetooth for example.

| improve this answer | |
  • "If pinging www.google.com resolves to an IP address then the issue is not related to DNS lookup." Not true. The DNS server may be misconfigured and resolve some addresses correctly while others not (for example only resolve addresses cached). – m0skit0 Oct 19 '11 at 14:24
  • 1
    Thanks @m0skit0 but he's tried OpenDNS and Google DNS so I doubt that is the problem. Clarified answer anyway. – Yeodave Oct 19 '11 at 16:28

After much research I stumbled upon the solution. I ran ipconfig /all when I noticed something weird called "Teredo Tunneling Pseudo-Interface". According to this Microsoft post, Teredo is an address assignment and automatic tunneling technology that provides unicast IPv6 connectivity across the IPv4 Internet.

It appears to me to be a defective feature. This pdf file indicates how to disable the service. Quoting from the file:

  1. Click Start, then Control Panel.
  2. Click on “System and Maintenance” link.
  3. Click on “Device Manager”.
  4. In device manager, click the “View” menu and select (tick) “Show hidden devices”.
  5. Expand the “Network Adapters” tree.
  6. Right click on “Teredo Tunneling Pseudo-Interface” and select “Disable”.
  7. Right click on “6to4 Adapter” and select “Disable”.
  8. Right click on the selected network card (Wireless or LAN) that you are working on and click disable, then re-enable it. This is simply to refresh the card which can also be done via reboot.
| improve this answer | |
  • I tried this(I didn't have 6toAdapter though), but no luck. – Daniel Kmak Aug 27 '15 at 19:34

Simply uninstall msie11 then reinstall using the typical method for system installed programs. Uncheck the box follow instructions then return to check the box and reinstall and restart like before. Possibly reset MSIE11 to original default settings. I then could access twitter after upgrading to win10.

| improve this answer | |
  • What is "the typical method for system installed programs"? Where do you go, what do you do? How do you reset it to default settings? It would be good if you could add some detail to your answer. – Mokubai Aug 9 '15 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.