My mouse has been working fine until recently when I booted up my computer, it would load fully, but when I tried to move the cursor it wouldn't move, and my keyboard didn't work either. I rebooted a couple times but the same thing happened until I tried switching the mouse.

The problem is: I have tried the mouse on other computers just to confirm that it is really not working. However, the "spoilt" mouse works on all the other computers in my home.

I have looked up for other solutions like reinstalling the driver but in order to do that I need the computer to read the mouse and it doesn't work because it causes my computer to hang upon startup and there is no way for me to troubleshoot with the mouse plugged in.

I have also tried using another mouse on this computer and it works.

Do I have to do something on my computer so that I can use this mouse again? It's a USB mouse.

  • what kind of mouse?
    – Journeyman Geek
    Commented Oct 19, 2011 at 13:46
  • it's a usb mouse
    – Lynette
    Commented Oct 19, 2011 at 13:48
  • 1
    a generic one? no special drivers?
    – Journeyman Geek
    Commented Oct 19, 2011 at 13:49
  • i guess so, the first time i used it, it worked without me installing any drivers manually.
    – Lynette
    Commented Oct 19, 2011 at 13:50

3 Answers 3


Perhaps the problem isn't in the mouse, since it works in other computers.

possibilities and solutions:

  • problem in usb port: try a different one
  • problem in the usb hub (inside your motherboard): change to a very different usb port (to use another hub), and try again
  • problem with something in your motherboard: change it
  • problem with the computer power supply: if it doesn't provide enough power, or have something malfunctioning in it, it can lead to erratic behaviour. Try changing it before changing the motherboard
  • i have tried using another mouse on the computer and it works, so is it a hardware or software problem? it seems like that mouse is suddenly not compatible with my computer
    – Lynette
    Commented Oct 19, 2011 at 14:25
  • try connect the other mouse (any mouse that works), go to the system configuration (device manager), remove all the hardwre and make windows recognize it again. Commented Oct 19, 2011 at 14:57

It might take a little troubleshooting and actual work i'm afraid, since this seems to be a very specific set of circumstances. It would help to have an EXACT name and model of mouse to check for unusual things

Stuff to try

  1. Try booting the system with another mouse, and plugging in the problem mouse with the other mouse plugged in

  2. check event viewer to see if there's any events at the same time.

  3. Switch USB ports around.


Try this, go to that link and find the exact OS and bit type of your OS, and manually install that package. http://support.microsoft.com/kb/2529073

alternativly find that specific update KB2529073 in your history of updates and install or re-install it. This will just up and replace most of the USB drivers, in the OS.

Then do a full Cleanup of your USB devices in the device manager also, to finish up.

To cleanup the mess in device manager, follow this tutorial exactly http://www.sevenforums.com/tutorials/77614-device-manager-hidden-devices.html to see the "ghosted" items in there. Go into Device manager and make sure that you set VIEW Hidden Devices, Then uninstall all the ghosted USB items, and then reboot.

If you have a newer computer or motherbaord: Do not plug your USB input devices into any USB3 ports on your computer. And if you have USB3 on the motherboard and sent it to a hub or a Front case connection point, it may not be compatable with USB3. If your have overclocked, Set any Overclock back to default speeds for testing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .