I asked before here: USB device not working properly on a Thinkpad T60

I accepted the answer but the problem has not been solved.

I have finally found this:

Usb not working

I am not very secure dealing with changing things that might destroy my computer.

Can anyone direct me to a safe way of solving this?

OS is Windows XP SP3.

  • Have you figured out what device is failing? Have you attempted to see if the problem is reproduced when you have less then 10 devices plugged in. There is only so many devices that can be installed, the limit is 255, but the number of devices allowed per USB HUB is much lower. – Ramhound Oct 19 '11 at 18:26
  • The problem still happens with less than 10 plugged in. – Xavierjazz Nov 22 '11 at 2:32
  • I suspect this is the answer: superuser.com/questions/419198/… – Xavierjazz May 10 '12 at 3:35

You could try to find out what device it is using its hardware ID. There's a great tutorial on how to do that.

If you know what device it is, you can look for the driver on your laptop manufacturer's site.

  • I took it to my tach. It is a phantom usb device apparently on the Bluetooth bus. I have no bluetooth device enabled. My tech disabled the message so it is no longer a problem. +1. Thanks. – Xavierjazz Mar 28 '12 at 2:49

Have you gone to the Lenovo site and downloaded latest drivers? I would check the Intel Chipset package if your system uses the Intel chipset. Lenovo also has a tool at the same site that will check all drivers and present you with a list of latest versions. It may list Update Retriever v4.2 for that product.

  • +1, thanks. Tried this, downloaded chipset drivers, no joy. What else might I need to download? – Xavierjazz Oct 21 '11 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.