26

I'm using emacs gui in Gnome. After pressing ctrl+z, emacs window is minimized. However, if I bring the window to front, it doesn't respond any key press and mouse event. I searched the web only found bringing back it within the commandline. But how to reactive emace when using it in a GUI mode ??

23

If you press C-z by mistake then you can add this to your .emacs to make C-z do nothing:

(global-unset-key (kbd "C-z"))

I did that after pressing C-z many times by accident.

  • resize the window (as posted below) to fix now! And then do this to make it permanent. Thanks from someone who has to constantly switch German and US keyboard layout. – ruquay Mar 31 '17 at 9:44
17

Type

fg 

or

fg %emacs

to get Emacs back.

7

You may have to send the process a SIGCONT signal. You normally do this in the console by running kill -CONT $emacs_pid or killall -CONT emacs. If you insist on a GUI solution, you can try the task manager shipped with your distro.

5

Send it a CONT signal:

killall -CONT emacs

A WINCH signal also seems to work, so you can just resize the Emacs window.

Clicking on any menu items seems to work as well.

If you were running Emacs from a terminal, fg ("foreground") or %emacs would work.

0

To turn off it in Vim add to your .vimrc:

map <C-z> <Nop>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.