10

I use two monitors (different makes and models but the same 1280x1024 resolution) on my Windows 7 Ultimate x64 system. The GPU is an nVidia GeForce 8600GTS, using driver version 8.17.12.8026 dated 3 August 2011.

Whever I boot the system, Monitor 1 appears to the right of monitor 2, but on my phiscal desktop, monitor 1 is on the left and monitor 2 on the right. I go into the control panel and drag them into the correct order and check the 'make this my primary display' for monitor 1. Great! everything works exactly as I want.

But next time I boot, it's all gone back to the previous arrangement. Frustrating! This is not a problem I've seen before with Windows 7, normally it works very well, remembers my settings and gets everything right. So I think something is wedged.

Any insights on putting this right? How do I get my settings to 'stick'?

1
  • This is a strange one the NVidia drivers and 8 series cards are usually pretty good with keeping settings... How are you configuring your monitors? The windows utility or the Nvidia control panel? Oct 27, 2011 at 14:18

4 Answers 4

12

I've seen this happen occasionally, and usually it's a problem with the initial monitor enumeration. Oftentimes changing to a much newer or older driver revision might fix it - specifically with that card, try removing the Nvidia driver ENTIRELY and just use the one that comes out-of-the-box with Windows 7.

Alternatively, since this is only two monitors, you might just consider physically reversing the manner in which they're cabled (so it enumerates them in the opposite order).

(If this has always been a problem with this machine, it's possible it's something screwy with this particular GPU, I guess. You could always use Displayfusion or Ultramon or something to automate the process of reversing the order of the screens with a hotkey or the like.)

1
  • Ah, but the problem persists regardless of monitor wiring! That's the first thing I tried. Somwhere along the line, the software is enumerating the monitors then actively swapping them over.
    – Tim Long
    Nov 1, 2011 at 2:28
5

I got an email notification that a new driver was available, so I did the update and selected the 'clean install' option. The problem has now gone and my monitor configuration is being persisted correctly. Ho hum.

2
  • 6
    At the risk of being self-aggrandizing, I feel the need to point out that my first suggestion was to remove the currently running driver...it's poor etiquette to answer your own question when somebody else already posted the solution you used...
    – Shinrai
    Nov 1, 2011 at 14:23
  • 1
    I would agree, except that it was the upgrade that fixed the problem.
    – Tim Long
    Feb 16, 2016 at 0:36
0

Check your BIOS Settings

I had the same problem as originally listed here and tried a lot of different things that seemed to work but after reboot it would revert back.

Finally I went into the bios at boot up and discovered that there was an option to choose primary display.

0

Here is the hotfix from Microsoft for Win7.

However I fixed the problem without installing the hotfix therefore I cannot comment on whether the fix works. My solution was that I disabled a service in windows called Windows Live Mesh remote connections service.

3
  • Hotfix didn't work for me
    – s6mike
    Oct 23, 2014 at 21:56
  • Link is broken.
    – AresAvatar
    Jul 21, 2015 at 15:00
  • Link Fixed.....
    – Moab
    Jun 12, 2018 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.