Some time ago I mapped a network drive on my Snow Leopard Mac, which was upgraded to Lion. The network drive is not active any more and I receive popups all the time with the error:

There was a problem connecting to the server XXXX.

I have no idea how I configured at the time. I may have included a mount command, in a config file but I don't know any more where I did it.

I reviewed the Preferences/Account/Login items and there is no permanent mapping there.

OSX is updated as Nov 27,2011 and the issue is not related to the upgrade to Lion itself but to a misconfiguration.

Any help will be greatly appreciated.

(If you have the opposite problem, here is the link to solve it: Permanently map a network drive on Mac OS X Leopard)

  • Can you check Utilities » Console.app for any relevant messages when this happens? There could be tons of ways to do this automatically. – slhck Oct 28 '11 at 16:36
  • Slhck. Thanks for your reply. I've fund the console plenty of errors and I was able to track down the misbehaving application (crashplan.app) which left behind a lunchd(eamon) script. Thanks again. your reply was insightful. – Flijfi Oct 28 '11 at 20:06
  • Sure, no problem! It would be best if you could answer the question yourself. There's a button "Answer Your Question" below, just put in what you had to do to solve it! – slhck Oct 28 '11 at 20:07
  • Sadly I was wrong. After a while messages came back and I receive the popup every few seconds. The console is crowded of messages but I couldn't find any relevant to "mount" or File errors or even with the name of the missing network connection. I'm open to new ideas. Thanks – Flijfi Nov 4 '11 at 11:01

I was getting this random pop up randomly...

(screen captures available at: drivecreative/fix )

that said, "There was a problem connecting to the server "M17".

I use to have my 17" laptop connected via wifi to my MacPro. If my laptop was off, I would often get this dialog telling me that M17 was missing.

Which it was.

If my laptop was on, then no random messages. So far so good. But what happens when you replace your laptop with a new MBPr with a new name? Well.. you get these little reminders about your missing machine whether you want them or not...

To stop the madness...

in finder, go to the "Go" menu and select "Connect to Server..."

After the "Connect to Server" window pops up, click the button with the "clock icon" and select "Clear Recent Servers..."

A scary dialog box pops up, click "ok" if you are not scared.

E r i c W h i t e { D r i v e C r e a t i v e . n e t }

(screen captures available at: drivecreative/fix )


It would be nice if we had a "Forget" button on the dialog this dialog so it would be obvious how to resolve this issue.

It would be nice to be able to just clear the one connection that is giving you issues instead of doing a "clear entire list" solution we have now...

  • 2
    This doesn't work for me. The list is empty. Still the damn alert keeps popping up all the damned time... – Kebman May 20 '13 at 12:15

I found that in my case those "There was a problem connecting to the server xxx" happened because they were in open automatically list. Here is how you can remove those:

  1. Go to System preferences > Users and groups > Select your user account
  2. Select tab Login items
  3. Select network mounts from list that you don't wont open automatically anymore and press minus button

(Be sure to have clicked the lock icon below in order to make changes.)


I found after updating from Snow leopard to Lion that FSTAB mounts have now been removed and replaced with automount binaries.

I could not find where or what config file repeatedly mounted my inaccessable nas share.

Every time i "umount" or forced un mount using diskutil e.g. sudo diskutil umount force /Volumes/nas it kept re appearing.

Finally after studying automountd and what Apple decided to do with -static mounts other than fstab, installed server admin tools (apple web site) for Lion and used Apple Directory Utility and under mounts there it was HOW ANNOYING but issue is now resolved. No more hanging or /Volumes/xxxxx

Utility is in /System/Library/CoreServices and you can launch with

Open Directory\ Utility.app

Then drop down mounts

Those more familiar with Unix would type open Dire so that it auto completes the command.

I found a quicker way to get to the Directory Utility:

  1. Go to System preferences > Users and groups > Login options.
  2. Press the Join button next to network account server.
  3. Press open Directory Utility, then as before go to mounts in the drop down.
  • Yay! Login options was what my problem was. – Peter K. May 23 '15 at 18:14

I had the same problem.

I had Bonjour Mounter installed that kept trying to SMB to the old NAS drive, my issue started when I changed the IP address of my NAS Device and wouldn't quit. After reviewing the console I found out that Bonjour Mounter kept attempting to access the old IP.

The fix, I updated Bonjour Mounter with the new IP address and the issue is gone now. I am not sure what to do if you actually use the Finder >> Go Menu >> "Connect to Server" option to smb://ipaddress/ to your NAS Directly ...

I believe if you install Bonjour Mounter you can view and update and old Servers that you may be connecting to. If you have Bonjour Mounter - go fix the IP address of delete it, if you dont have Bonjour Mounter, Install it and it might actually show you the hidden Server IP your OS is trying to get to and from there you should be able to delete it


The IP address my popup was complaining about appeared in a CUPS config file under /etc.

The popups went away after removing a stale printer definition from System Preferences » Print & Scan.


I network my MSI laptop to my Macintosh Computer, which was fine until i closed my laptop and got a dialog box on my mac saying “ there is a problem connecting to the server”, but when i open my laptop, it didn’t show up.

I ONLY use my laptop for certain things, like 3D art and such. and i hate the ideal of having to open my laptop if I’m using my mac.

So this did work for me, so I hope this works for you.

  1. First clear the recent servers address on your computer, just hold down Command/K and goto the clock looking icon and go down to “Clear Recent Servers”.

  2. Then make a new folder on your desktop so you can copy all the files in the Preferences folder to it.

  3. goto Library/Preferences and copy all the files to the folder you made on your Desktop, then trash all the files in the Preferences folder, then i restart my computer, this should add new Preferences to the Preferences folder on your computer.

  4. copy all of the Preferences files from your desktop Back to Library/Preferences and it will ask you to Authenticate, just click on Authenticate Button, then it will ask to replace the existing files, ONLY click on the Replace button.

  5. Restart your computer, that should do it, you will have to re-set some Preferences back to the way you had it, for me it was the Energy Saver settings and my monitor setup, you should not get the pop-ups dialog box saying “ there is a problem connecting to the server ”.

I hope this helps


I have found that the barracuda copy app causes this on my desktop and likely my macbook just haven't tested. Yep just to make sure I launched it and cannot even type this till I turn it back off as the cannot connect to local server keeps popping up - never would have guessed. I see no way to change that in its settings, did open a ticket with them. In my case this solved the problem. No other low level or advanced hack has ever worked, but simply quitting COPY does. Moral check and see if you use COPY from barracuda networks.

  • and yes I checked for alias to old drives or servers – Barrett Apr 3 '15 at 17:45
  • I have reproduced this on both desktop and macbook air. 10.10.2 So far barracuda/Copy support claims it's just my OS problem. Can any of you confirm whether you use the Copy app ? If so , do as I do quit the app and silence the unneeded server dialog pop ups. – Barrett Apr 7 '15 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.