67

I was trying to install Zend Server CE on my computer but when I got to the point were I need to choose the port for my Web Server it says: "Web Server Port: 80 Occupied". So I decided to check what is using Port 80 with CMD by typing: "netstat -o -n -a | findstr 0.0:80":

TCP     0.0.0.0:80     0.0.0.0:0     LISTENING     4

I check for PID:4 in Task Manager's Processes and Services. Seems PID 4 is "System".

So, what I want to know is how can I stop "System" (PID:4) from using Port 80?

INFO: I am using: Windows 7 64bit; Zend Server CE 5.5.0

7
  • Wouldn't hurt to telnet a "GET / HTTP/1.1" to 127.0.0.1 and see what comes up.
    – LawrenceC
    Commented Oct 30, 2011 at 3:18
  • @ultrasawblade How exactly do I do that? Commented Oct 30, 2011 at 3:28
  • 1
    Run telnet 127.0.0.1 80 and then past that line in and press enter twice. If you're running Windows 7, you need to install telnet client from "add and remove Windows features" first.
    – billc.cn
    Commented Oct 30, 2011 at 22:35
  • 1
    World Wide Web Publishing service in Windows 8 64 for me did the trick.
    – user187014
    Commented Jan 10, 2013 at 19:17
  • 3
    HTTP service state can help you to identify the running services in case of PID 4. Run netsh http show servicestate and look at registered URLs or Logging information.
    – pazadev
    Commented Jun 13, 2016 at 15:44

7 Answers 7

91

Ok, after searching the web for a while I found a solution to my problem.

Just follow these steps to diagnose and resolve your issue:

  1. Get pid that is listening port 80: netstat -nao | find ":80"

  2. Open task manager, go to processes tab and check “PID” in Menu/View/Select Columns…, then look for the process using the PID found in last step.

  3. If it is a normal application or IIS, disable it or uninstall. Some programs (such as Skype) have the option to disable its use of port 80.

  4. If it is a System Process—PID 4—you need to disable the HTTP.sys driver which is started on demand by another service, such as Windows Remote Management or Print Spooler on Windows 7 or 2008.

    There is two ways to disable it but the first one is safer:

    1.

    • Go to device manager, select “show hidden devices” from menu/view, go to “Non-Plug and Play Driver”/HTTP, double click it to disable it (or set it to manual, some services depended on it).

    • Reboot and use netstat -nao | find ":80" to check if 80 is still used.

    2.

    • Launch RegEdit.

    • Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP

    • Change the value of "start" to 4, which means disabled.

    • Reboot your computer.

My solution was step 4.

17
  • 5
    Where is the "Non-Plug and Play Driver" tree in the device manager of Windows Server 2012? Commented Dec 21, 2014 at 19:16
  • 5
    The device manager approach isn't available from Windows 8 onwards.
    – Roddy
    Commented Aug 28, 2015 at 8:27
  • 2
    The registry solution worked on Win8. I miss Linux. Commented Sep 4, 2015 at 18:13
  • 10
    Please tweak this a little bit. Disabling the "HTTP" service in Windows disables all of it's dependencies. The specific service using port 80 is "W3SVC" (The World Wide Web Publishing Service), a dependency of "HTTP". This can be verified by running "net stop W3SVC" from an Administrative Command Prompt, and then 'netstat -n -o -a | find ":80"' to verify nothing is listing on port 80 anymore. I recommend disabling the World Wide Web Publishing Service (W3SVC) instead (if you don't want to disable SSDP, the Print Spooler, HomeGroup, and Function Discovery).
    – chriv
    Commented May 3, 2016 at 19:32
  • 4
    I don't understand this instruction at all Go to device manager, select “show hidden devices” from menu/view, go to “Non-Plug and Play Driver”/HTTP, double click it to disable it (or set it to manual, some services depended on it). There is no Non-Plug and Play Driver”/HTTP menu item anywhere. Commented Apr 13, 2017 at 8:42
33

I just had this issue after installing Windows 8 Pro - Build 9200. I tried several methods but couldn't get any of them to work. This one, however, fixed it.

You need to change the binded IP address for HTTP.SYS

netsh http add iplisten ipaddress=::

http://www.mikeplate.com/2011/11/06/stop-http-sys-from-listening-on-port-80-in-windows/

4
  • This solution is great, when you need to both run a server that does not use http.sys, and one that does. Commented Feb 11, 2013 at 21:29
  • 1
    Also worked for me. What does it actually do though?
    – akame
    Commented Sep 10, 2015 at 20:44
  • 3
    I thought this fixed my issue because it did free up the port but it also had some other side effects. Specifically, I was unable to bind to specific hostnames via IIS after this change. To undo I used netsh http delete iplisten ipaddress=:: Commented Mar 7, 2016 at 1:52
  • This worked for me, but had side effects. Please see my answer below for a possible alternative that uses the same command, but a different IP address. Commented Apr 24, 2017 at 16:56
7

On my case it was WebMatrix. See possible solutions (including this one) here: http://www.sitepoint.com/unblock-port-80-on-windows-run-apache/

Basically:

Open Services from Administrative Tools and locate “Web Deployment Agent Service”. Stop the service and set it’s startup type to “Manual”.

The Web Deployment Agent Service is deployed with WebMatrix and was the cause of my woes. It may also be distributed with other applications installed using Microsoft’s Web Platform Installer.

1
  • Also the problem I was having (on Windows 10) Commented Oct 18, 2016 at 10:57
6

PID 4 is hard coded to be the "System" process which is part of the system kernel.

If the port is occupied by the system, you probably had IIS enabled. See https://stackoverflow.com/questions/1430141/port-80-is-being-used-by-system-pid-4-what-is-that

9
  • I have uninstalled IIS 7.5 Express thinking that would help. Maybe I have to restart? I am going to try that. Commented Oct 30, 2011 at 3:05
  • Nope. Problem still persists. Commented Oct 30, 2011 at 3:19
  • Do you have IIS 7.0 (the one shipped with Windows 7) installed as well? Normally if you just stop w3svc, the port will be closed.
    – billc.cn
    Commented Oct 30, 2011 at 13:34
  • Nope. And as far as I know, I shouldn't have any other webservers installed either. Commented Oct 30, 2011 at 20:52
  • 1
    I just stoped and disabled MSSQLEXPRESS services Worked instantly see: stackoverflow.com/a/3136943/1435526
    – BOB
    Commented Feb 22, 2014 at 14:22
3

While using the command netsh http add iplisten ipaddress=:: did, indeed, allow Apache to start on my Windows 10 64 bit system, it wreaked havoc with trying to access localhost, as that was bound to :: instead of 127.0.0.1, even with the proper entry in my hosts file. What I ended up doing was to use this command instead: netsh http add iplisten ipaddress=0.0.0.0 This not only worked, but allowed browser access to localhost as well. For me this was a superior solution.

2
  • While you method didn't work for me (I still get a 404 page from an unknown web server running locally) it did make me try to go to 127.0.0.1 which works as a workaround as long as you remember it Commented Jan 7, 2020 at 17:19
  • Just found out, if you tried to add :: you need to delete :: as well, then it will work with localhost as you described Commented Jan 7, 2020 at 17:21
3

Open the Services list Find "World Wide Web Publishing Service" Stop it, and set it to Manual

0

I had process blocking a port that I needed to use for a docker container and it took forever to resolve. In my case it was PID 4 using port 80 too.

Thought I'd summarise all of the potential issues and solutions I found while trying to resolve - hopefully useful for someone else in future.


For anyone new coming to this, you can investigate the service using the respective port by following these steps to try to figure out what it is.

In Powershell we can check for what process is using this port:

netstat -aon | findStr /i "LISTENING"  | findStr ":80"

To check what process this is:

tasklist /FI "PID eq 4"

Another way to get the process ID using the port:

Get-Process -Id (Get-NetTCPConnection -LocalPort 80).OwningProcess

Check whether the port has ben reserved for use by another process with:

netsh int ipv4 show excludedportrange protocol=tcp

Also look in Resource Monitor to see if that gives you any more clues.


I tried all of the suggestions I found here and in other posts:

None of these worked to free up the port.

In the end I decided to check for any recent Windows Updates that could have caused it - there was nothing new in the last two weeks.

But when I check for recently installed applications (using Bulk Crap Uninstaller - it's excellent!) I noticed two 'apps' installed yesterday which I definitely didn't manually install so I think they somehow came through Win Update or an auto app update:

  • Microsoft Edge Webview 2 Runtime
  • Web Components

After uninstalling these, I had access to port 80 again!

To make sure it wouldn't happen again, I reserved the port for my own use:

netsh int ipv4 add excludedportrange protocol=tcp startport=80 numberofports=1
1
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places.
    – DavidPostill
    Commented Apr 26, 2023 at 7:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .