I have a small nas from iomega. Two drives 500 gb each. This one. The two harddrives in the enclosure were configured in a mirror with the iomega software that came with product. It worked for a couple years but I think it overheated in my closet. One of the drives stopped showing up in the array and then a few days later the harddrive enclosure shut down completely. When I tried to turn it back on it would attempt to boot but then shut itself down after 20 seconds or so. I thought the enclosure itself might be the issue so I pulled the drives out of the enclosure. I have a sata HDD dosking station which lets you plug a SATA drive into it to get usb access.This thing. I plugged the drive I thought was still good into it.

The drivers for the HDD docking station seemed to install fine on the computer when I plugged it in but the drive does not show up in windows explorer (windows 7 on toshiba laptop). The drive does show up in disk management but I cannot assign a drive letter to it. In fact when I right click on the drive in disk management the only option I get is delete volume. The drive shows two partitions one 996GB and one 464GB. One concerns might be that nothing is listed under file system for the volumes. See image for details. Any ideas for what I should try next to get access to the files? Thanks.

Disk Managment


There will be some inforation in the partition sector regarding the RAID configuration, and Windows doesn't understand it.

It is also possible that it isn't formatted as NTFS, but ext4 or another linux file system, and just exposed to your network as a Windows share.

If you don't have Linux installed anywhere, my recommendation would be to get a linux live cd such as ubuntu and boot up your PC using it - with the usb drive attached. It is quite likely linux will figure out what is on the disk as the iomega NAS was probably using a linux derivative.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.